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Abstract

Cancer cell motility and invasion are key features of metastatic tumors. Both are highly linked to 

tumor microenvironmental parameters, such as collagen architecture or macrophage density. 

However, due to the genetic, epigenetic and microenvironmental heterogeneities, only a small 

portion of tumor cells in the primary tumor are motile and furthermore, only a small portion of 

those will metastasize. This creates a challenge in predicting metastatic fate of single cells based 

on the phenotype they exhibit in the primary tumor. To overcome this challenge, tumor cell 

subpopulations need to be monitored at several timescales, mapping their phenotype in primary 

tumor as well as their potential homing to the secondary tumor site. Additionally, to address the 

spatial heterogeneity of the tumor microenvironment and how it relates to tumor cell phenotypes, 

large numbers of images need to be obtained from the same tumor. Finally, as the 

microenvironment complexity results in nonlinear relationships between tumor cell phenotype and 

its surroundings, advanced statistical models are required to interpret the imaging data. Toward 

improving our understanding of the relationship between cancer cell motility, the tumor 

microenvironment context and successful metastasis, we have developed several intravital 

approaches for continuous and longitudinal imaging, as well as data classification via support 

vector machine (SVM) algorithm. We also describe methods that extend the capabilities of 

intravital imaging by postsacrificial microscopy of the lung as well as correlative 

immunofluorescence in the primary tumor.
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1 Introduction

Metastasis remains the leading cause of breast cancer-related deaths. Unlike the primary 

tumor, which can be managed in the clinic with chemotherapy and surgery, there is currently 

no effective treatment for metastasis [1]. Metastasis is a complex, multistep process, during 

which cancer cells dissociate from the rest of the primary tumor, move through the tissue 

and disseminate to secondary organs [2]. Chemical and physical cues from the tumor 

microenvironment, i.e. host cells [3] and the extracellular matrix (ECM) [4–6], play a 

significant role in shaping cancer cell behaviors related to metastasis, namely epithelial-to-

mesenchymal transition (EMT), motility, invasion, homing, etc. Complex and dynamic 

interactions between tumor cells and the tumor microenvironment result in shifting the 

balance between cell behaviors accessible from the current genetic and transcriptomic 

landscape as well as the emergence of new cancer cell phenotypes [7, 8]. To understand such 

interactions at the single cell level in a quantitative fashion, it is essential to image cancer 

cells in real time in the context of their native niche.

With the emergence of multiphoton microscopy [9], it has become possible to study in vivo 

dynamic events in real time in mouse models, a notable example being intravital imaging of 

cancer cell motility [10]. Compared to confocal microscopy, multiphoton imaging allows 

deeper penetration and decreased light scattering as a result of excitation cross-sections 

being in the nearinfrared range of wavelengths. Furthermore, the use of femtosecond pulse 

lasers allows acquisition of second harmonic generated (SHG) signals, produced by 

noncentrosymmetric structures, including collagen I fibers abundant in most solid tumors. 

Unlike fluorescent signals, which need to be exogenously supplied to the sample, SHG 

signal is endogenous and originates from the dipole orientation of collagen fibers [11, 12].

Continuous intravital imaging in mouse models is generally limited to several hours, which 

allows high quality measurements of motility parameters in tumor cells as well as host 

immune cells [13, 14] or fibroblasts [15]. In addition, blood vessel flow and collagen 

architecture can be measured simultaneously. However, to fate-map specific cells or niches 

within the tumor, observations need to include metastatic events such as intravasation and 

lung colonization, which occur on a scale of days. As common intravital microscopy in 

tumors does not allow for freely moving animals, animals are anesthetized [16, 17] and 

imaging is limited to 5–24 h. Hence, longitudinal imaging [18, 19] is necessary to map the 

journey from primary to secondary tumor site. To ensure monitoring of the same tumor 

regions over multiple (static or continuous) imaging sessions, the utilization of 

photoconvertible fluorophores, such as Dendra2, is optimal [20, 21]. Dendra2 irreversibly 

switches green-to-red following 405 nm exposure, enabling us to track tumor cells 

longitudinally.

In this chapter we provide a guide to performing intravital imaging of cell motility in 

photoconvertible Dendra2-labeled breast carcinoma tissues and image analysis. We 

introduce the surgical procedures and lay out the steps for real-time, continuous imaging and 

analysis of 4-color, 4D stacks demonstrating two different motility phenotypes of tumor 

cells: fast- and slow-(invadopodia-driven) locomoting cells. Microenvironmental features are 

extracted from the same 4D stacks and finally, SVM classification identifies the 
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microenvironmental conditions amenable to presence of fast- or slow-locomoting cells. We 

describe how photoconversion can be used in vivo for longitudinal imaging of the same 

regions of interest. Lastly, we discuss postsacrificial approaches that can extend the 

capabilities of intravital imaging of lung metastases and correlative immunofluorescence of 

the primary tumor sections.

2 Materials

2.1 Intravital Imaging and Photoconversion

1. Mouse strains:

a. MMTV-PyMT × MMTV-iCre/CAG-CAC-Dendra2 (cytoplasm of all 

tumor cells labeled with photoconvertible Dendra2).

b. MMTV-PyMT × MMTV-iCre/CAG-CAC-Dendra2 × c-fms-CFP 
(cytoplasm of all tumor cells and macrophages labeled).

c. MDA-MB-231-Dendra2 cells orthotopically injected into SCID mice.

2. Olympus FV1200MPE multiphoton laser scanning microscope.

3. UPLSAPO 30× objective with silicone oil immersion, NA 1.05.

4. ThorLabs PM200 Handheld optical power and energy meter.

5. Temperature control environmental chamber.

6. Infrared heating pad.

7. Isoflurane.

8. Anesthesia mask.

9. Surgical drape.

10. Tissue forceps.

11. Micro scissors.

12. Trimmer.

13. Ocular lubricant ointment.

14. 70% ethanol.

15. Sterile 1× PBS Dulbecco’s phosphate-buffered saline (1× PBS).

16. Dextran, Texas Red, 70 kDa (Molecular Probes).

17. MMPSense 680 Fluorescent Imaging Agent (PerkinElmer).

18. Transfer pipettes.

19. Cotton-tipped applicators.

20. Insulin syringe.

21. Super glue liquid, longneck bottle.
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22. Labeling tape.

2.2 Immunofluorescence

1. 1× Dulbecco’s phosphate-buffered saline (1× PBS).

2. Fixative: 4% paraformaldehyde, 1× PBS.

3. O.C.T. (optimal cutting temperature) Compound.

4. 30% w/v sucrose solution.

5. Isopentane (2-methylbutane).

6. Dry ice.

7. Disposable cryomolds.

8. Positively charged microscope glass slides.

9. Blocking Solution: 1% bovine serum albumin (BSA), 1% fetal bovine serum 

(FBS), 1× PBS.

10. Liquid Blocker Super Pap Pen.

11. Permeabilization Solution: 0.1% Triton X-100, 1× PBS.

12. Acetone.

13. Antibodies and fluorescent dyes: Anti-Ki67 (Abcam, cat. abcam15580, 1:200), 

Anti-fibronectin (Abcam, cat. ab6328, 1:100), Phalloidin conjugated to Alexa 

Fluor 633.

14. Fluoromount-G mounting medium.

15. Cover glass.

16. Nail polish.

3 Methods

3.1 Surgical Preparation

The animals must be surgically prepared for imaging by removing skin and exposing the 

cells to be imaged. Here, we briefly describe the mammary skin flap procedure, which is 

suitable for continuous imaging. For the skin flap preparation, the mammary tumor tissue of 

the fourth inguinal mammary gland is separated from the peritoneum on a skin flap (Fig. 

1a). The fourth inguinal mammary gland is sufficiently distant from the chest area, which is 

most heavily affected by breathing. Separation from the body with the skin flap further 

reduces breathing disturbance on imaging. This approach is technically simple and is 

suitable for short, one-time imaging sessions only. The imaging time is limited to generally 

6–8 h due to inflammation and blood vessel damage as a result of prolonged exposure of the 

tissue to the outside environment. This duration can be increased to 24 h with careful 

monitoring of vital signs [18, 23]. Repeated imaging is not advised and the animal is 

commonly sacrificed after imaging.
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In the event that repeated longitudinal imaging is desired, mammary imaging window 

preparation is more appropriate (Fig. 1a). The imaging window, which consists of a glass 

coverslip on top of a plastic or a metal ring [19, 24], is sutured into the skin on top of the 

tumor tissue. The animal is allowed to heal for 3 days, after which it is available for 

continuous, noninvasive imaging and daily, longitudinal monitoring. The advantage of this 

approach is the prolonged monitoring (up to 21 days) of a developing tumor. With additional 

points of reference (photoconvertible fluoro-phores, fluorescent microbeads, photo-tattoo 

[25]), which can be used to monitor the same region of interest. However, this method 

requires additional surgery training for personnel and a three-day post surgery recovery time 

for the animal.

3.2 Labeling Blood Vessels and/or Macrophages

Intravenous, tail vein injection of 70/155 kDa fluorescent dextran (100 μg) will label active 

blood vessels [26]. 2–6 h following injection, the 70 kDa probe will extravasate and label the 

phagocytic subpopulation of macrophages [27]. For imaging total macrophage population, 

using transgenic mouse models is advised [23, 28] (see Subheading 2.1, item 1). Note that 

macrophage labeling will remain present for 5–7 days.

3.3 Image Acquisition

1. The animal is placed in an environmental chamber at 37 °C with continuous 

1.5% isoflurane flow for the maintenance of anesthesia. 50 μL of sterile 1× PBS 

is administered intravenously (tail vein) every hour for hydration.

2. Locate a region of interest in the primary tumor, characterized by the presence of 

flowing blood vessels and bright fluorescence signal. Avoid areas rich in 

adipocytes as they scatter excitation light and obstruct fluorescence (Fig. 1b, c).

3. Acquire 4D stacks for the duration of interest (generally 30–60 min).

4. If longitudinal imaging of the acquired area is needed, proceed to 

photoconverting regions of interest (Subheading 3.8).

3.4 Detection and Quantification of Fast-Locomoting Cells

Translocating or motile cells are characterized by the extension of the cell front, movement 

of the center and the contraction of the rear.

1. Open a 4D stack in ImageJ.

2. Correct for movement by running HyperStackReg plugin to align sections in XY 

plane [29].

3. Visually score each z-section of the 4D stack movies for the morphological 

determinants of tumor cell fast locomotion. For the ease of processing, field of 

view (FOV) can be divided into smaller (1/4) sections (Fig. 2a, left panels). 

Select one z-section for further analysis.

4. Subtract frame taken at time 0 from the frame taken at time 60 min (Process > 
Image Calculator > Subtract images). Acquire an image with all pixels 
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translocated during the time period. This step can be performed for differences 

between any two time points (Fig. 2a, middle panels).

5. Threshold the image to remove background fluorescence (Image > Adjust > 
Threshold).

6. Using Particle Analysis plugin in ImageJ, count the number of locomoting cells 

and obtain the mask of cell translocation. By adjusting the values for particle size 

and circularity, false positives, such as cell edges due to XY shift attributed to 

breathing artifacts, can be removed (Fig. 2a, right panels) (Analyze > Analyze 
Particles > Size (15 μm2-infinity), Circularity (0.1–1)).

7. Compare the mask with the 4D stack and ensure that all locomoting cells have 

been captured.

8. If not all locomoting cells are captured, readjust values for size and circularity in 

the Particle Analysis tool.

9. Manually remove remaining false positives, such as cell edges due to motion 

artifacts (Draw ROI > Edit > Fill).

10. Run Particle Analysis tool on the final processed image to obtain the count of 

locomoting cells.

11. Merge the obtained mask of locomoting cells with the frame at time 0 to 

visualize initial tumor cell position and track of movement (Image > Color > 
Merge Channels).

3.5 Detection and Quantification of Invadopodia in Slow-Locomoting Cells

Invadopodia are highly dynamic, small protrusions on the surface of tumor cells, 

characterized by finger-like morphology, <3 μm wide and <7 μm in length, and extension/

retraction cycles. In vivo, invadopodia go through extension and retraction cycles of 3–20 

min [30, 31], as well as change the position of the growing tip, making the selective 

identification via motility analysis possible. Importantly, only the cells exhibiting 

invadopodia-driven slow locomotion phenotype will successfully metastasize to the lung 

[31, 32].

1. Open a 4D stack in ImageJ.

2. Correct for movement by running HyperStackReg plugin to align sections in XY 

plane [29].

3. Visually score each z-section of the 4D stack movies at 2–4× zoom for the 

morphological determinants of tumor cells with invadopodia. For the ease of 

processing, cells can be analyzed individually (Fig. 2b).

4. Subtract frame taken at time 0 from the frame taken at 3 min to 15 min (Process 
> Image Calculator > Subtract images) (see Note 1). Acquire an image with all 

pixels translocated during the time period.

5. Threshold the image to remove background fluorescence (Image > Adjust > 
Threshold).
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6. Using Particle Analysis, count the number of invadopodia per cell and obtain the 

mask of the dynamics of invadopodia over the time period. By adjusting the 

values for particle size and circularity, one can remove false positives such as cell 

edges due to XY shift (Analyze > Analyze Particles > Size (0.5 μm2-infinity), 
Circularity (0–1)).

7. Compare the mask with the 4D stack and ensure that all invadopodia have been 

captured.

8. If not all invadopodia are captured, readjust values for size and circularity in the 

Particle Analysis tool.

9. Manually remove remaining false positives (Draw ROI > Edit > Fill).

10. Run Particle Analysis tool on the final processed image to obtain the count of 

invadopodia.

11. Overlay the obtained mask of translocated protrusions with the frame at time 0 to 

visualize the extension/retraction of invadopodia (Image > Color > Merge 
Channels) (Fig. 2b).

12. Migration of the entire tumor cell body of invadopodia-driven slow-locomoting 

cells can be captured by extending the time-lapse imaging to 5–8 h.

3.6 Analysis of the In Vivo Microenvironmental Parameters

Features we routinely monitor in the tumor microenvironment include the density of 

collagen fibers, tumor cells and phagocytic macrophages, as well as the number and 

diameter of flowing blood vessels present in the FOV. Directionality and alignment of 

collagen fibers [33] and speed of blood vessel flow [34] can also be incorporated into the 

analysis without additional labeling. In animals where total macrophage population is 

labeled via c-fms promoter (see Subheading 2.1, item 1a), the number and speed of 

(non)phagocytic macrophages can also be quantified. Finally, the amount of degraded ECM 

can be measured via the injection of the protease-activatable imaging probe MMPSense 680, 

whose fluorescence increases >10-fold following proteolysis by key matrix 

metalloproteinases (MMP-2, -3, -9, and -13) [31].

1. Open a multicolor 4D stack in ImageJ.

2. Z project all frames using the maximal intensity mode (Image > Stacks > Z 
Project).

3. Visually score the entire 4D hyperstack and duplicate the 3D, 4-color stack at 

first time point (see Note 2) (Fig. 1c).

4. Separate channels and apply a smoothing filter (Process > Smooth). To measure 

collagen fiber alignment, save the image corresponding to the collagen channel 

using “.tiff” format and follow steps 10–14.

5. Threshold each channel to remove background fluorescence (Image > Adjust > 
Threshold) (see Note 3) and obtain binary images for each parameter (Fig. 2c).
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6. Measure the density of collagen fibers and tumor cells, defined as the percent 

area above threshold in each corresponding channel (enable the function “Limit 

to threshold” under Analyze > Set Measurements).

7. Separate macrophages from blood vessels on the basis of size and morphology in 

the dextran channel (Analyze > Analyze Particles).

8. Determine the number of flowing blood vessels and measure the diameter of the 

largest flowing blood vessel visible in the FOV using the “Straight Line” tool.

9. Manually count the number or measure the density of macrophages labeled with 

70 kDa dextran in the FOV.

10. To measure collagen fiber alignment, import the image saved in step 4 to ctFIRE 

software [33] (Import image/data) (see Note 4).

11. Optimize the accuracy of fiber detection by adjusting the parameters (see Note 
5).

12. Run fiber detection analysis. The nonoverlaid and the reconstructed images are 

displayed (Fig. 2c′). If the overlaid fiber map shows non-negligible errors in 

fiber detection, click on the Reset button and adjust the detection parameters 

(step 11).

13. When fiber detection is satisfactory, check “Straightness histogram & values” 

and “Angle histrogram & values” under section “Select Output,” and run the 

postprocessing analysis (see Note 6), which will return the histograms for 

Straightness (Fig. 2c′) and Angle (not shown).

14. Use the corresponding data set created in the output folder “…\ctFIREout” under 

the working directory to compute the average alignment of the collagen fibers in 

each direction.

15. Select the Reset button to import a new image.

3.7 Support Vector Machine Classifications

To determine the range of microenvironmental parameters amenable to fast- versus slow-

motility phenotypes, SVM classification is used [35]. SVM is a supervised learning model, 

which constructs hyperplanes in high-dimensional spaces [36] that are nonlinearly related to 

the input. Depending on the complexity of the input data, the hyperplane can be as simple as 

a line dividing a two- dimensional space into two regions, or as complicated as a set of 

multidimensional nonlinear planes dividing the space into multiple zones. The discrete 

regions created by hyperplane(s) represent distinct classes that SVM recognizes among the 

input data. SVM algorithms are available for many mathematical packages, including 

Rstudio which is freely available. In this work, a nonlinear SVM from R-package “e-1072” 

[36] is used for data classification.

The source code (MotilityClassifier.R) for data classification is provided for download as a 

Supplementary File. The code receives the input data as a tab delimited text file and creates 

a SVM model with a “radial” kernel vector. Within the code, the details of each step are 
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provided as comments. Briefly, the code randomly selects 90% of the input data for the 

learning process, based on which it generates a SVM model. The model is further tuned by 

iterative changing of the “cost” and “gamma” values until the “bestmodel” with the least 

error is achieved. Using this model, the code predicts the motility phenotype of the 

remaining 10% of the data and prints a table reporting the precision of the classification by 

indicating the percentage of misclassified data (green spheres, Fig. 2d). A low 

misclassification percentage (<5% in Fig. 2d) means that the input variables of two classes 

are statistically different and can be used for predicting the type of cell motility.

3.8 Photoconversion for Longitudinal Intravital Imaging

3.8.1 Determining Optimal Photoconversion Settings

1. Using the optical power meter, measure the power level of the 405 nm laser that 

enters the sample.

2. Define a range to test between 0 and 600 μW (Fig. 3a). In this case, the power 

settings are 20% (1 μW), 30% (4 μW), 40% (64 μW), and 50% (520 μW).

3. Balance the intensities of green to the background of red in a nonsequential scan 

before photoconverting.

4. Open “Live Plot” window to track the fluorescence intensities of red and green 

channels.

5. In Time Scan window, set Interval to “Free Run” and Number to “20.”

6. Set the 405 nm laser to the power level being tested and start scanning. Monitor 

the Live Plot window and stop scanning as soon as red fluorescence intensity hits 

a plateau or green fluorescence intensity drops (photobleaching).

7. Out of four settings tested, 20% (1 μW) and 30% (4 μW) laser powers are too 

weak to induce photoconversion (Fig. 3b′, b″). 40% (64 μW) laser power is 

optimal with efficient photoconversion and with minimal photobleaching of the 

green fluorescence (Fig. 3b, b″). 50% (520 μW) laser power is too strong and 

results in complete photobleaching of the fluorescent signal (Fig. 3b, b″).

3.8.2 Photoconversion of Tumor Cells In Vivo—After continuous imaging of the 

region of interest, decide on the area to be photoconverted

1. For a single cell, select the Point tool and place it at the center of the cell.

2. Using the optimal settings determined in Subheading 3.8.1 (64 μW laser power), 

scan until red fluorescence signal plateaus.

3. The photoconverted proteins diffuse and fill the entire cell (Fig. 3c, top left 

panel).

4. For a single area, use the selection tool to draw a rectangular region of interest 

(see Note 7) and scan (Fig. 3c, top right panel).
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5. For photoconverting several regions (Fig. 3c, bottom left panel) or all cells in that 

field of view (FOV) (Fig. 3c, bottom right panel, see Note 8) the same tool as in 

step 4 can be used (see Note 9).

6. Using photoconverted regions as tissue landmarks, the same FOV can be located 

at multiple imaging sessions, allowing longitudinal imaging of tumor cells and/or 

microenvironmental parameters (Fig. 3d).

3.9 Ex Vivo Imaging of Lung Metastases

Breast cancers commonly metastasize to the lung, liver, brain, and bone. Likewise, in our 

mouse models, we observe single cells and micrometastases in the lung. Counting the 

number of single cells and colonies is suitable for assessing total number of metastases 

following euthanasia of the animal at the end of imaging. Additionally, the number of red 

metastases can be measured at a set time point (2–7 days) following photoconversion, 

enabling the measurement of dynamics of tumor cell homing, proliferation, or dormancy 

[37] in the lung. Dendra2 red variant is highly stable and protein turnover in vivo is 

negligible ([21, 24]; therefore, with each cell division red fluorescence is diluted by 50%. As 

the non-photoconverted green variant of Dendra2 is continuously being synthesized under 

the CMV promoter, cells will become orange and yellow following cell division(s) (Fig. 4a

′). The origin of green cells cannot be delineated, as they can be both descending from 

yellow cells, or arriving from the nonphotoconverted green regions of the primary tumor.

1. Immediately after sacrificing, secure the mouse in supine position by taping the 

legs to the surgical surface.

2. Make a midline incision on the chest, open the skin and peritoneum, exposing 

the ribcage.

3. Cut through the bones and cartilage to open up the ribcage. Absorb blood with 

tissue paper.

4. Harvest the lung tissue and transfer it to a dish with 1× PBS.

5. Separate two lobes of the lung and quickly rinse with fresh 1× PBS.

6. In a drop of 1× PBS, transfer the lung to a coverslip or a glass-bottom 

microscope dish for imaging.

7. Image metastatic lesions in 20 random FOV (Fig. 4a).

8. Using image processing, quantify the number of metastases:

a. Open image in ImageJ.

b. Remove background fluorescence and set threshold (Image > Adjust > 
Threshold).

c. Count the number of cells (Analyze > Analyze Particles > Size (15 
μm2-infinity), Circularity (0.1–1)).
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3.10 Correlative Immunofluorescence

1. After imaging and photoconversion, harvest the tumor tissue and immediately fix 

in 4% paraformaldehyde solution for 1 h at room temperature and then overnight 

at 4 °C.

2. Wash the tissue in cold 1× PBS for 1 h at 4 °C.

3. Incubate tissue in 30% sucrose solution overnight at 4 °C.

4. In a cryomold, immerse the tumor tissue in O.C.T compound, orient it and freeze 

it in an isopentane bath (see Note 10).

5. The frozen tissue can be stored at −80 °C until ready to be sectioned.

6. Using a cryostat, section the tissue sample into 6–10 μm thick slices and mount 

onto positively charged microscope glass slides.

7. The slides can be stored at −80 °C until ready to be stained.

8. Wash off O.C.T. compound from tissue sections by repeatedly dipping slides in 

water.

9. To permeabilize tissue sections, immerse slides in permeabilization solution for 

10 min. Alternatively, sections can be permeabilized for 10 min in ice-cold 

acetone (procedure we use for labeling microenvironmental parameters, such as 

endomucin, laminin, collagen IV, collagen I, or fibronectin).

10. Briefly air-dry slides.

11. Draw a circle around each tissue section with a liquid blocker pen to provide a 

barrier for solutions.

12. Block tissues with 50–100 μL drops of the blocking solution for 2 h at room 

temperature. Alternatively, block tissues overnight at 4 °C. To prevent 

evaporation, place slides into a humidified chamber.

13. Incubate with primary antibodies diluted to appropriate concentrations in 50–100 

μL of blocking solution for 3 h at room temperature, in a humidified chamber.

14. Wash by dipping slides in 1× PBS.

15. Incubate with secondary antibodies and DAPI diluted in 50–100 μL of blocking 

solution for 2 h at room temperature in a humidified chamber and protected from 

light.

16. Wash by dipping slides in 1× PBS.

17. Briefly air-dry slides.

18. Place a drop of Fluoromount-G on each tissue section.

19. Avoiding air bubbles, place a glass coverslip and seal with nail polish.

20. The glass slides with tissue sections can be stored at 4 °C and protected from 

light, until ready to be imaged.

Bayarmagnai et al. Page 11

Methods Mol Biol. Author manuscript; available in PMC 2019 January 01.

A
uthor M

anuscript
A

uthor M
anuscript

A
uthor M

anuscript
A

uthor M
anuscript



21. Image cryosections (Fig. 4b–e).

4 Notes

1. The choice of time points for invadopodia analysis depends on the frequency of 

extension–retraction cycles.

2. Identify a time-point when all microenvironmental parameters of interest are 

clearly visible. For example, to visualize blood vessels, it is advised to start 

imaging immediately after injection of fluorescent dextran. For phagocytic 

macrophages, inject the animal with fluorescent dextran >3 h prior to the 

imaging session. Both blood vessels and macrophages will be visible in the time 

window of 1–3 h following injection.

3. For the first set of images in the series, suitable threshold value is set manually. 

At that time, users can decide on a satisfactory automated thresholding method 

(Image > Adjust > Auto Threshold drop down list). The threshold value will 

need to be adjusted for each imaging session if the acquisition parameters differ.

4. The ctFIRE software requires MATLAB compiler runtime (MCR 7.17 2012a) 

installation.

5. A description of each parameter can be found in the User Manual (available at 

http://loci.wisc.edu/software/ctfire). We recommend starting with default values. 

The parameters and the options under the sections “Output Figure Control” and 

“Select Output” can be modified after fiber detection, during the postprocessing 

step (see step 13).

6. Additional outputs can be selected: “Overlaid fibers,” “Non-overlaid fibers,” 

“Angle histogram & values,” “Length histogram & values,” and/or “Width 

histogram & values.”

7. Areas containing >20 cells are easier to locate later in cryosections and 

determine the orientation of the tissue.

8. Photoconverting all four corners of the FOV is a useful method if one plans to 

perform correlative immunofluorescence. This way, the FOV can be located by 

the photoconverted corners, while leaving the rest of the FOV available for 

labeling in the red channel. Photoconversion of the entire FOV is useful if the 

number of photoconverted cells needs to be maximized, such as postsacrificial 

imaging of lung metastases.

9. Alternatively, all cells in the FOV can be photoconverted using the mercury or 

LED lamp excitation through the DAPI filter [38]. Locate the area of interest and 

expose it to the lamp on full power for 5–10 min. This method yields 

photoconverted FOV with diffuse edges. If an area larger than a single FOV is 

needed, custom-built LED array can be used to expose the entire surface under 

the mammary imaging window to 405 nm light [24, 31].

Bayarmagnai et al. Page 12

Methods Mol Biol. Author manuscript; available in PMC 2019 January 01.

A
uthor M

anuscript
A

uthor M
anuscript

A
uthor M

anuscript
A

uthor M
anuscript

http://loci.wisc.edu/software/ctfire


10. To prepare the isopentane bath, fill a stainless steel container with isopentane and 

place it in dry ice. Drop a few pellets of dry ice into isopentane and wait for the 

boiling to stop. At this time isopentane is chilled to about −90 °C and is ready for 

freezing the sample. Slowly lower the sample and drop it in the isopentane bath. 

Leave it until the entire block is frozen through and the sample sinks to the 

bottom of the isopentane bath.

Supplementary Material

Refer to Web version on PubMed Central for supplementary material.
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Fig. 1. 
Surgical preparation and intravital images of the tumor microenvironment in transgenic and 

orthotopic xenograft mouse models of breast carcinoma. (a) Surgical preparations of mice 

for intravital imaging: skin flap (top) and mammary imaging window (bottom). (b) Intravital 

image of tumor cells and the surrounding tumor microenvironment in carcinoma stage of the 

MMTV-PyMT × MMTV-iCre/CAGCAC-Dendra2 transgenic mouse at 13 weeks. Tumor 

cells (green), blood vessels (red), collagen fibers (magenta), macrophages (cyan). Scale bar 

50 μm. The image is reprinted with permission from [22]. (c) Intravital image of tumor cells 

and the surrounding microenvironment in the orthotopic xenografts of MDA-MB-231-

Dendra2 cells. Tumor cells (green), blood vessels (red), collagen fibers (magenta), 

macrophages (cyan). Scale bar 25 μm
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Fig. 2. 
Intravital Systems Microscopy: Multiparametric SVM classification of tumor cell 

locomotion and microenvironmental parameters (a) Identifying and quantifying fast-

locomoting cells. Left panels, raw images of an individual z-section from the 4D stack (at 0 

and 60 min; 0′ and 60′). Middle panels, 0′ was subtracted from 60′, resulting in Δ60 (top); 

image was then thresholded/binarized (bottom). Right panels, results of motility analysis 

including quantification of fast locomoting cells (top) and the overlay with the 0′ image 

(bottom). Scale bar 50 μm. (b) Identifying and quantifying invadopodia in slow locomoting 
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cells. Raw images of a cell at time 0, with fully extended invadopodium at 3 min and 

partially retracted invadopodium at 15 min. Overlays Δ3 and Δ15 show invadopodia 

extension highlighted in magenta. Scale bar 10 μm. (c) Binarized images used for extraction 

of microenvironmental parameters. Image in Fig. 1c was separated and thresholded, 

resulting in binary images of collagen (magenta), tumor cells (green), macrophages (cyan) 

and blood vessels (red). (c′) Collagen fiber map (left) and dimensionless straightness 

histogram (right) from ctFIRE software. (d) 3D projection of SVM classification results. 

Red spheres denote slow locomotion, blue-fast locomotion, green- misclassifications. The 

size of the spheres indicates the number of locomoting cells in the FOV. Dmax (μm) stands 

for the diameter of the largest blood vessel in the FOV, macrophages (%) and collagen (%) 

stand for the thresholded area in respective channels
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Fig. 3. 
Intravital photoconversion of Dendra2-labeled tumor cells (a) Relationship of the 405 nm 

laser power setting to laser power entering the tumor tissue. Measurement was done at the 

focal plane of UPLSAPO 30× objective. (b) Photoconversion efficiency at power settings 

20–50% in a MDA-MB-231-Dendra2 xenograft section. (b) Green channel shows the effect 

of photobleaching at each power setting. (b′) Red channel shows the emission of 

photoconverted red Dendra2 at each power setting. (b″) Merge. Scale bar 50 μm. (c) 

Photoconversion of a single cell (upper left panel, zoom in the insert), 150 × 100 μm region 
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containing ~100 cells (upper right panel), four 100 × 100 μm regions (lower left) and the 

entire FOV (lower right). Scale bar 50 μm. (d) Collagen fibers imaged at 0 h and relocated at 

24 h using photoconverted region as a reference point. Scale bar 50 μm
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Fig. 4. 
Photoconversion as a multiplexing tool: Intravital imaging and photoconversion followed by 

imaging of lung explants and immunofluorescence of primary tumor (a) Ex vivo imaging of 

lungs of animals imaged and photoconverted in vivo. A single photoconverted red cell in the 

lung (a) and a metastatic colony (a′) observed at 90 h postphotoconversion. Collagen fibers 

are shown in magenta. Scale bar 50 μm. The image in a′ is reprinted with permission from 

[31]. (b–e) Immunofluorescence in cryosections of primary tumors imaged and 

photoconverted in vivo. Additional labels are shown in purple: proliferation, Ki67 (b), blood 

vessels, CD31 (c), actin cortex, phalloidin (d), ECM, fibronectin (e). Scale bar 50 μm
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