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Open-ended laboratory projects increase student success 
and retention in the sciences.  However, developing 
organismal-based research projects is a challenge for 
students with restricted laboratory access, such as those 
attending courses remotely.  Here I describe the use of 
image analysis of zebrafish neural development for 
authentic research projects in an introductory biology 
laboratory course.  Zebrafish are a vertebrate model that 
produce large numbers of externally and rapidly developing 
embryos.  Because zebrafish larvae are transparent, 
fluorescent reporters marking nervous system structures 
can be imaged over time and analyzed by undergraduate 
scientists.  In the pilot of this project, remote first-year 
college students independently developed biological 
questions based on an image collection comparing 
zebrafish mutants and wild-type siblings.  Students created 
and mastered techniques to analyze position, organization, 

and other morphological features of developing neurons and 
glia in the images to directly test their biological questions.  
At the end of the course, students communicated their 
project results in journal article format and oral 
presentations.  Students were able to hone skills in 
organismal observation and data collection while studying 
remotely, and they reported excitement at applying lecture-
based knowledge to their own independent questions.  This 
module can be adapted by other instructors for both 
students on- and off-campus to teach principles of neural 
development, data collection, data analysis, and scientific 
communication. 
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Authentic inquiry experiences early in collegiate careers are 
associated with improved outcomes for undergraduate 
science students, with increases in learning gains, 
persistence in the field, and sense of belonging (Bangera 
and Brownell, 2014; Indorf et al., 2019; Buffalari et al., 2020).  
The COVID-19 outbreak necessitated a shift to online, 
remote learning for many introductory labs.  Although 
studies suggest that students can perform research projects 
as well remotely as in-person (Kirkpatrick et al., 2019; 
Doctor et al., 2021), lab course content had to be 
significantly adjusted.  One challenge for all labs, but 
particularly at the introductory level, was providing authentic, 
open-ended inquiry involving data collection and analysis for 
students studying remotely. 
     Image analysis is frequently employed in research 
studies but is taught less often than traditional wet-lab 
techniques in introductory laboratories.  Because image 
analysis can be done entirely on a computer after collecting 
data at the microscope, it is well-suited to remote learning.  
Furthermore, undergraduate students can derive suitable 
questions for open-ended inquiry when provided with an 
image collection that contains multiple parameters to 
analyze (Pemberton et al., 2018; Nahmani, 2019). 
     Zebrafish larvae are particularly amenable to live imaging 
and analysis, even for novices and at the introductory level 
(Pike et al., 1992; Marra et al., 2015; Peterson et al., 2018; 
Wilk et al., 2018; Prakash and Toro, 2019).  Zebrafish are 
small, freshwater teleosts that produce many larvae from a 
single cross of a fertile male and female.  External 
fertilization permits phenotypic analysis of nervous system 
patterning across time in a single living animal, while rapid 
embryonic development results in identifiable spinal cord 

and peripheral nerve patterning within 3 days post-
fertilization.  Transgenic fluorescent reporters can be used 
to label neurons and glia in different genetic backgrounds 
and are readily observed in transparent larvae.  Importantly, 
the major genetic regulators of nervous system 
development are conserved from zebrafish to humans, 
allowing students to draw connections to disease 
mechanisms. 
     Here, I present a laboratory module using image analysis 
of the larval zebrafish nervous system for remote open-
ended inquiry in an introductory laboratory course.  In the 
pilot of this module, remote first-year biology students used 
an instructor-created collection of images of novel zebrafish 
mutants with mispatterned nervous systems and compared 
them to age-matched wild-type siblings.  This allowed 
students to develop their own testable questions about the 
development of neurons, glial cells, and related structures 
and tissue types in a vertebrate model system.  Students 
then designed appropriate image analysis techniques using 
Fiji (ImageJ with Bio-Format Importer) to test their 
predictions, analyzed their data using R programming via 
RStudio, and presented their findings in written and oral 
format.  In all, students were able to collect and handle novel 
data and develop analytic skills for independent inquiry while 
in a remote laboratory course setting. 
 
PROJECT DEVELOPMENT AND RESOURCES 
Learning Objectives and Skills Objectives 
Following this project, students should be able to: 
 Distinguish neuroanatomical features of the zebrafish 

nervous system, including central and peripheral 
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nervous systems, sensory and motor nerves, and 
neuron soma and axons 

 Apply neuroanatomical terminology for orientation 
(dorsal vs. ventral, anterior vs. posterior) and cellular 
features (soma vs. axons) of zebrafish nervous 
systems 

 Identify, compare, and contrast normal (wild-type) 
nervous system patterning with aberrant (mutant) 
neural development 
Additionally, students develop skills in the following 
areas: 

 Use primary literature to gain content knowledge and 
as models for writing scientific papers 

 Collaborate with peers in experimental design 
 Use Fiji to measure neuroanatomical features in 

fluorescent micrograph images 
 Analyze data and produce graphs using RStudio 
 
Course Structure 
The introductory biology laboratory at Kenyon College, BIOL 
109-110Y, is a year-long course typically taken by first- and 
second-year students.  This course is required for students 
majoring in neuroscience, biology, and molecular biology 
and serves as a prerequisite for upper-level lab courses in 
those fields.  The goals of the course are to develop 
experimental design, data collection and management, 
analysis, and writing skills.  By the end of the first semester 
(prior to the project period), students are familiar with 
reading literature, setting up datasheets for data collection, 
descriptive and inferential statistics, and creating graphs in 
RStudio.  Thus, this module can be incorporated into the end 
of an introductory course, or as part of a course with more 
senior students that are proficient with these skills.   
     In the second semester of this year-long course, students 
develop an independent project in consultation with a faculty 
mentor and write a research project proposal.  Project 
development is carried out in parallel to “traditional” inquiry-
based labs in the first seven weeks of the semester; that is, 
students strategize with prospective mentors outside of, and 
in addition to, weekly lab course meetings (Table 1).  In the 
final seven weeks of the course, students carry out their 
proposed project with a partner.  Students independently 
perform data collection and analysis, with their work 
culminating in a final oral presentation and complete project 
 

Week Activity 

1-4 
Identification of project mentor, reading literature, 
meeting with faculty  

5 
Submit annotated bibliography of five papers related 
to project 

6-7 Draft and submit independent project proposal 

8-13 
Data collection, analysis, and writing.  Weekly reports 
submitted to course instructors detailing progress, 
goals, and literature read 

14 Oral presentation in-class 

15  Final project paper in style of journal manuscript 

 
Table 1.  Independent project structure by course week. 

paper in the style of a journal article manuscript.  In Spring 
2021, students enrolled in this course were mixed in-person 
and remote; on-campus students (46 of 82) generally 
conducted research projects in person, while remote 
students (36 of 82) were limited to remote research projects.  
Six remote first-year students participated in this 
independent project of zebrafish image analysis. 
 
Zebrafish Larvae Rearing and Imaging 
Early in the second semester (~8 weeks before projects 
commenced), zebrafish larvae were crossed, collected, and 
imaged by the instructor to create the database for student 
analysis.  This project used the novel stl159 mutant that was 
previously identified in a forward genetic screen with 
multiple developmental defects in peripheral nervous 
system patterning (manuscript in preparation).  Additional 
suitable mutants are also available, as are pharmacological 
manipulations; these would be generally useful for this 
module (see “Opportunities for modification or extension”.)  
     Presently, the stl159 lesion is not fully characterized 
genetically; therefore, progeny were considered siblings or 
mutants based strictly on their phenotype.  For this study, 
heterozygous adults for the novel stl159 lesion were crossed 
to produce homozygous wild-type and heterozygous 
stl159/+ siblings, which have a normal patterning phenotype 
called “wild-type”, and stl159 homozygous mutants, which 
have broad mispatterning of the peripheral nervous system 
referred to as “mutant” (Figure 1).   
     Larval progeny of heterozygous crosses were sorted for 
the presence of two transgenes.  All imaged larvae 
contained a transgene that expresses red fluorescent 
protein in neurons under the control of the neural b-tubulin 
promoter, nbt:dsRed (Peri and Nüsslein-Volhard, 2008).  
Fluorescent dsRed protein can be strongly observed in 
neuron cell bodies in the brain and spinal cord, but also in 
axons that extend throughout the peripheral nervous 
system.  Additionally, larvae expressed sox10:megfp, which 
is predominantly expressed in neurons and glia within the 
spinal cord as well as neural crest derivatives, including 
Schwann cells in the peripheral nervous system (Smith et 
al., 2014).  These transgenic strains are available for 
distribution from the original study authors and other groups. 
     Individual dsRed+; mEGFP+ larvae from two different 
clutches of stl159/+; nbt:dsRed; sox10:megfp parents were 
sorted and placed individually in numbered 24-well dishes at 
24 hours post-fertilization (hpf), before peripheral nerves are 
patterned.  In total, 34 larvae were sampled (22 from first 
clutch, 12 from second) with 30 used for the image 
collection.  At 36, 48, and 72 hpf, larvae were removed from 
their individual wells, anesthetized with 0.02% tricaine, and 
imaged in 9-well glass dishes.  Brightfield, dsRed (dsRed 
filter cube), and mEGFP (GFP filter cube) was imaged  using 
a Zeiss Discovery V.8 fluorescent dissecting stereoscope 
with Axiocam 506 color camera.  Care was taken to take 
images consistently; for instance, exposure was held 
constant (500 ms), larvae were oriented in a lateral view 
horizontally across the image field, magnification (32x, 50x, 
and  80x) was chosen that showed the same wide-field and 
detailed features for every larva, and the yolk extension was 
included in high-magnification images of the midbody to  
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Figure 1.  Lateral schematic of key nervous system features in a zebrafish larva.  The anterior lateral line nerve (ALLn) and posterior 
lateral line nerve (PLLn) are sensory nerves.  Motor nerves are shown emanating from spinal cord.  Boundaries of body wall muscle 
segments (somites) are shown in gray.  Compass denotes dorsal (D)-ventral (V) and anterior (A)-posterior (P) axes.  (B-E) Patterning of 
wild-type sibling (B-C) and stl159 mutant (D-E) larvae at 72 hours post-fertilization (hpf).  (B, D) Brightfield lateral view shows normal 
melanocyte patterning in sibling and disrupted in mutant (arrowhead).  (C, E) Merged nbt:dsRed; sox10:megfp fluorescence in larvae 
shown in B and D indicating features scored by students.  PLLn position is marked with white arrow, spinal cord is marked with bracket, 
subset of motor nerves from spinal cord are marked with asterisks.  PLLn and motor nerve phenotype are disrupted in stl159 mutants.  
Merged image created in Fiji; students scored merged or single channel images depending on research question. 

 
orient the dorsal-ventral and anterior-posterior axis.  All 
images were saved in .czi (Carl Zeiss ZEN software) format. 
 
Zebrafish Image Database for Analysis 
Representative images for each larva at each timepoint,  
illumination (brightfield, dsRed, mEGFP), and magnification 
were selected for the image collection.  Images were 
renamed consistently to indicate sample number and 
parameters: The first number in the filename (e.g., 01, 02, 
etc.) denoted a single larval specimen imaged at multiple 
timepoints.  For example, all images in the database 
collection labeled “19” represented the same larva; 19-36 for 
36 hpf, 19-48 for 48 hpf, and 19-72 for 72 hpf, with 
magnification and illumination to follow.  Magnification is 
noted second in the filename.  At 36 hpf, larvae were imaged 
at 50x and 80x.  At 48 hpf and 72 hpf, larvae were imaged 
at 32, 50, and 80x.  Illumination/transgenes was noted last; 
mEGFP = sox10:megfp (glia) and dsRed = nbt:dsRed 
(neurons).  White light, or brightfield, was marked BF.   
     Google Drive was used to store and distribute images for 
remote student use, with the entire dataset >10GB.  
Students were directed to download a subset based on their 
research question if they lacked hard drive space or fast 
internet while working remotely.  The naming format 
described above allowed students to selectively download 

samples of interest without needing to download the entire 
image dataset.  The database may be available to 
instructors upon request. 
 
INDEPENDENT PROJECT STRUCTURE 
Early in the second semester, students identified a project 
mentor, developed their research question, and wrote an 
independent project proposal.  The subsequent seven-week 
project period consisted of four general steps: continued 
research of literature and zebrafish anatomy, work in FIJI to 
view images and collect data, data analysis using RStudio, 
and presentation of their work orally and in a written 
manuscript (Table 1).  During the project period, students 
met with their project mentor, as well as course instructors 
and classmates, at least weekly for updates and feedback.  
Although these steps typically occurred in that order, it was 
not a strictly linear process.  Below are details for each step 
before and during the project period. 
 
Project Preparation and Development (~3-4 Weeks, 
Concurrent with other Lab Activities) 
Background and Literature Review 
Students were encouraged to rely upon primary literature 
discussing zebrafish nerve analysis suggested by the 
instructor for their initial inquiry into lateral line  
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Nervous system features 

Spinal cord The spinal cord includes cell bodies as well as axons emanating from these neurons and from the brain.  
Axons are grouped into tracts which run anterior to posterior in the dorsal and ventral parts of the spinal cord.  
Spinal cord tracts are often more visible with glial markers that enwrap axons than with neuronal markers. 

Lateral line 
nerves (LLn) 
 

LLn are superficial sensory nerves that are relatively easy to assay in larvae, though they are less prominent 
than the spinal cord.  LLn are paired, with one anterior (ALLn) and one posterior (PLLn) on each side 
(left/right).  The ALLn encircle the eye, while the PLLn extend posteriorly from approximately the ear to the 
tail.  In a lateral view, typically only one PLLn is in focus, though the other may be visible through the 
transparent body.  The lateral line ganglia (LLg) are posterior to the ear.  The ALLn are near the brain, and 
the bright fluorescence there obscures the small ALLn.  The PLLn are more obvious in these lateral views.  
The lateral line nerves innervate sensory organs called neuromasts, which are not visible with the nbt:dsRed 
transgenic marker.  Normally, the PLLn develops between the skin and at the meeting point of dorsal and 
ventral muscle, called the horizontal myoseptum.  Any deviations of the main nerve fascicle from the 
horizontal myoseptum, including axons or glia, are abnormal at these timepoints. 

Motor nerves Motor nerves are comprised of axons with cell bodies in the ventral spinal cord.  In early stages of development, 
there is typically one fasciculated motor nerve emanating from the spinal cord and extending ventrally along 
each muscle segment.  Motor nerves are not as medial as the spinal cord but not as lateral as PLLn; still, it is 
sometimes possible to see motor nerves on both sides of the transparent animal. 

Other major landmarks 

Muscle ~30 segments of body wall muscle appear as chevron shapes pointing posteriorly.  The “point” of the 
chevron is the horizontal myoseptum, a boundary between dorsal and ventral muscle blocks.  Body wall 
muscle serves as the substrate for developing peripheral nerves.  Motor nerves extend ventrally from the 
spinal cord centered on each muscle segment, while PLLn migrate along the horizontal myoseptum, crossing 
each segment while extending posteriorly. 

Yolk 
 

The yolk and yolk extension are prominent and useful landmarks in early zebrafish development.  At 36-72 
hpf, the yolk is a large ball ventral to the first ~8 muscle segments, with a thinner stretch of yolk extension 
ventral to the next ~7-8 more posterior segments.  These are always ventral to the body wall and thus 
provide dorsal-ventral orientation.  Additionally, the position along the anterior-posterior axis can be 
determined by checking whether nerves are dorsal to the yolk, yolk extension, or even more posterior.  This 
is critical because zebrafish development proceeds anterior to posterior; therefore, the same anterior-
posterior position should be analyzed across age-matched larvae. 

Melanocytes 
 

Melanocytes are dark pigment cells migrating throughout the skin of the fish.  They are neural crest-derived, 
as are Schwann cells; migrating crest cells also use muscle as a substrate.  While melanocytes are not part 
of the nervous system, they come from a similar lineage.  Melanocytes are dynamic during development but 
are typically located along the horizontal myoseptum, in patches on the dorsal and ventral aspects, and 
clustered directly above the yolk. 

Notochord 
 

The notochord is the fluid-filled primitive backbone of the fish prior to the development of the skeleton.  It 
provides flexible support to the larva and will eventually be replaced by vertebrae.  In brightfield images, the 
notochord is visible as a thick, depressed “stripe” along the anterior-posterior axis, ventral and parallel to the 
spinal cord. 

 
Table 2.  Major features and landmarks of zebrafish larvae for neurodevelopment analysis. 
 
(Gilmour et al., 2002; Schröter et al., 2008; Pujol-Martí and 
López-Schier, 2013; Thomas et al., 2015; D'Rozario et al., 
2017) and motor nerve patterning (Westerfield et al., 1986; 
Birely et al., 2005; Palaisa and Granato, 2007; Kucenas et 
al., 2008; Banerjee et al., 2015).  Additionally, students were 
given an instructor-prepared guide that described general 
larval zebrafish anatomy, the background of stl159, the 
image database, working in Fiji, and suggestions for 
statistical analysis.  The relevant parts of this guide are 
summarized in this paper, and the complete guide is 
available upon request. 
 
Orientation to Zebrafish Anatomy 
To correctly identify siblings and mutants and analyze 
salient phenotypes, students became familiar with the 
zebrafish larval features at 36-72 hpf.  In particular, they 
learned to identify relevant aspects of the nervous system 

(spinal cord, lateral line nerves, motor nerves) and major 
landmarks and features of the larvae (muscle segments, 
yolk and yolk extension, melanocytes, and notochord).  
Several of these features are shown in Figure 1, with 
descriptions provided in Table 2.  Additional reviews of 
peripheral nerve and muscle development, cited above, can 
provide more detail. 
 
Independent Research Proposal 
After students finalized a mentoring relationship with their 
faculty mentor, they reviewed relevant literature in an 
annotated bibliography.  Students were encouraged to study 
figures that had distinct differences in neural and glial 
architecture in larval zebrafish.  At the initial step of project 
development, students were not given access to the image 
database, so they could broadly develop interesting 
biological questions and methodology and understand the 



The Journal of Undergraduate Neuroscience Education (JUNE), Fall 2021, 20(1):A73-A82     A77 
 

state of the field.  Once students identified common themes 
in development (mispatterned or absent axons, glia, and 
melanocytes due to loss of genetic factors), they were given 
access to the image database and asked how they might 
apply that theme to this resource and biological question.  
Their questions are summarized below in “Student 
Outcomes and Discussion.”    
     Each student then individually wrote a proposal, 
generally ~2-3 pages, with an introduction, methods, 
materials, and literature cited.  The introduction provided 
essential background information along with the central 
research question and served as a draft of the introduction 
for the final paper.  The methods and materials sections 
were written in future tense for this assignment, though it 
also served as a draft for the final paper.  This section was 
reviewed by the instructor and mentor prior to starting full-
time research to ensure that students had developed an 
appropriate research question and defined a plan to answer 
a novel biological question using the image database.   
 
Working in Fiji (~3-4 weeks) 
After students were familiar with the anatomy and biology of 
their research question, they downloaded and installed Fiji 
on their personal computers and used the online ImageJ 
manual for guidance.  For getting started and 
troubleshooting, these sections were particularly helpful:  
Basics: https://imagej.nih.gov/ij/docs/concepts.html. 
Tools: https://imagej.nih.gov/ij/docs/guide/146-19.html. 
Measure: https://imagej.nih.gov/ij/docs/guide/146-30.html. 
      
Protocols for Working in Fiji: 
Converting .czi Files for Image Analysis 
Fiji can open .czi files, which includes image information and 
critical metadata.  Images can be readily opened in Fiji using 
the Bio-Formats Import Options using default settings.  
However, because .czi is a proprietary file format with large 
size, it can be challenging for novices relative to the .tif 
format.  Once students identify the necessary images for 
their research question, they should save files as .tif by 
converting to RGB color via the Image menu > Type > RGB 
Color, then saving as .tif using File > Save As.  Students 
should retain the same general filename with “(RGB)” 
appended to match the converted files to the originals.   
 
Adjusting Intensity for Image Analysis 
Because many features are labeled with nbt:dsRed and 
sox10:megfp, and because the image collection served a 
variety of research questions, a particular feature of interest 
sometimes needed enhancement with Image > Adjust > 
Brightness/Contrast.  This is due to the relatively short 
exposure time of the image to avoid capturing the vibration 
of the living fish in the water (Figure 2A).  However, these 
features can be revealed using the Brightness and Contrast 
(B&C) feature in Fiji.  The B&C pop-up box has a histogram 
showing the range of pixel intensities.  To show fine 
features, like small processes on motor nerves, the 
maximum and minimum intensities can be scaled using the 
sliders in the B&C box (Figure 2B).  Though this may 
saturate the brighter spinal cord, it permits visualization and 
analyses of dim features like motor nerves and PLLn.  While 

 
 
Figure 2.  dsRed expression in a 72 hpf zebrafish taken at 80x 
magnification.  (A) Raw low-exposure .czi image as it appears in 
Fiji.  The spinal cord (bracket) is prominent, and PLLn (arrow) is 
visible.  Motor nerves are too dim to observe.  Histogram (right) is 
scaled 0-255, with most pixel brightness values to the left.  (B) 
Scaled image shows PLLn (arrow) and motor nerves, including fine 
branched processes (arrowheads).  Spinal cord (bracket) is 
saturated and should not be analyzed using this image.  In the B&C 
box, the maximum is scaled so the display values correspond to 
the peaks in the histogram. 
 
gamma adjustment may be used to avoid saturation, non-
linear adjustments should not be used to quantitatively 
measure pixel intensity.  This enhancement works best in 
RGB color mode (not 16-bit or RGB Stack).  The scaled 
image for analysis should be saved as a copy with a new 
filename.   
     For intensity measurements, scaled images must be 
adjusted to the same degree; because images were 
collected with the same exposure and same conditions, the 
intensity can be directly compared if all images receive the 
same linear scaling.  For counting, measuring length, etc., it 
is less critical to adjust maximum intensity to the same 
identical degree for all images, but they should be at least 
similar so as not to introduce artefacts.  For instance, 
adjusting brightness in fluorescent images altered 
melanocyte appearance; thus, melanocytes should be 
analyzed only using brightfield images. 
 
Counting Features with Fiji 
Counting in Fiji is best accomplished with the point tool.  
Options for the point tool can be accessed by double-clicking 
in the toolbar.  Counting and measuring points is easiest with 
“Auto-measure” and “Add to Overlay” turned on.  Auto-
measure keeps a tally of clicked points in the Results 
window, which opens automatically.  Add to overlay 
essentially converts the point into a multi-point tool while 
also visually saving the dot position if saved as .tif.  Point 
labels can be turned on and off in with Image > Overlay > 
Hide Overlay to view both a marked-up and clear image in a 
single file (Figure 3A).  Results can be saved as a .csv for a 
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record of all measurements, e.g., those for a single 
specimen (Figure 3B).  These values, in addition to serving 
as a running tally of the counted features, can also be used 
to mark distance between features, measure position, etc. 
 
Measuring Features with Fiji 
Measuring is a two-step process; first, by carefully drawing 
a line along the feature (Figure 3A,C), then selecting 
Analyze > Measure (Figure 3B, D).  The Results window will 
indicate the length of the specified line.  New lines will also 
be recorded in the same Results window, as well as re-
measurements of the same line.  Fiji will use file metadata 
to provide values in microns.  The Pixel width value can be 
validated or adjusted in the Image menu > Properties.  
Totest that the pixel-to-micron conversion is correct, 
measure an image of a micrometer at the same 
magnification; if incorrect, calculate the correct ratio to set 
as Pixel width. 
     Drawing a new line will replace any previous line 
selections.  However, lines can be added to an overlay with 
Image > Overlay > Add Selection.  This allows a record of 
the lines drawn, and as with the point overlay, it can be 
toggled off with Image > Overlay > Hide Overlay.   
 
Creating Image Figures with Fiji 
Polished figures of representative images of the observed 
phenotypes should be alongside the quantification in 
presentations and papers.  Zebrafish micrographs are 
typically represented with anterior to the left and dorsal 
toward the top.  Images that are representative of the wild-
type and mutant phenotype for any parameter can be 
corrected to the same orientation using Image > Transform 
> Flip Horizontally / Flip Vertically / Rotate options.  To 
represent both dsRed and mEGFP fluorescence in a single 
image (e.g., Figure 1C, 1E), use the Image > Merge 
Channels function in Fiji. 
 
Data analysis (~2-3 weeks) 
Chi Square to Test Mendelian Ratio 
Most student projects predicted phenotypic differences 
between mutant larvae and wild-type siblings.  Therefore, 
most students began analysis by determining if they had 
identified the expected proportion of mutants.  Students 
independently binned larvae as “wild-type” or “mutant” 
based on differences in melanocyte or nerve patterning and 
manually calculated X2 Goodness-of-Fit tests to determine 
whether they had the expected ratio of siblings to mutants.  
For a recessive mutation inherited in Mendelian fashion, 
students predicted 25% would be mutant, or 7-8 out of 30. 
 
Analysis with RStudio 
Students in BIOL 109-110Y use R programming for data 
analysis beginning in the first weeks of the course.  By the 
independent project period, they are familiar with datasheet 
setup using Google Sheets, uploading and importing data 
as .csv files into their projects in rstudio.cloud, employing 
descriptive and inferential statistics, and creating data 
visualizations via ggplot2.  Students analyzed their data 
based on their questions of interest, typically using Student’s 
t-test to determine differences between wild-type and 

mutant groups at a single timepoint, or 1-way or 2-way 
ANOVA to compare across timepoints.   
 
Scientific Communication (1-2 weeks) 
Oral Presentation 
In the final class, students gave 15-minute presentations 
with their partner, with time to field questions from the 
audience.  The presentation included background material 
with research question, a brief explanation of methods, 
results including images and quantification with emphasis 
on biological findings, and a discussion to connect their 
results with the field.  To prepare their presentations, 
students were given explicit instruction on how to focus their 
work and present information concisely.  Students were 
graded using a rubric that was appropriate for both remote 
and in-person projects. 
 
Final Paper  
For the final assignment, students turned in a complete 
manuscript of their work in the style of a journal article 
submission.  Manuscripts included introduction, methods, 
results, captioned figures, discussion, acknowledgements, 
and references.  Additionally, students wrote a brief 
response to the feedback they received on their project 
proposal, which was generally rewritten to serve as the 
introduction and methods sections of their final papers.  This 
served as an exposure to writing a “Response to Reviewers” 
as part of the article publication process. 
 
Grading of the Independent Project 
As noted in Course Structure, the independent project was 
incorporated into a year-long course.  Within the project, 
students were assessed on their annotated bibliography (10 
points), project proposal (100 points), weekly progress 
reports (10 points each), oral presentation (60 points) and 
final paper (100 points).  Additionally, students received 
scores for participation and upkeep of the lab notebook 
throughout the semester, including the project period.    
 
STUDENT OUTCOMES AND DISCUSSION 
Development of Independent Questions 
The pedagogical goal was to develop inquiry-based remote 
research projects that were driven by students’ interests and 
agency.  Students were encouraged to choose biologically 
sound question(s) based on the literature and predict what 
nerve patterning phenotypes could result with different types 
of genetic disruptions.  For some questions, students 
predicted a difference across wild-type siblings and mutants, 
while for others, they would stay the same.  For instance, 
students predicted that central nervous system patterning 
might stay the same, while sensory or motor nerves would 
be mispatterned, if a gene specifically disrupts peripheral 
nervous system patterning.  This encompasses multiple 
testable hypotheses.  Highest emphasis was placed on 
ensuring that the data they were choosing to collect would 
tell a biological story. 
     At the beginning of the project, some students felt 
simultaneously overwhelmed by possibilities and boxed-in 
by the image collection.  Students developed very creative 
ideas for testing causation of patterning defects that would 
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Figure 3.  Counting and measuring features in Fiji.  (A) nbt:dsRed expression in 72 hpf larvae.  Spinal cord is indicated with bracket.  Five 
motor nerves are counted with the multi-point tool as indicated.  (B) Results window shown for five points on motor nerves.  Mean, Min, 
and Max report fluorescence brightness; because this is a point (with area 0), they are all the same, as there can be only one fluorescence 
value for a single point.  X and Y are the coordinate position for the point in the image.  Clicking additional points in the image would 
number those points and add values to the same Results window.  (C) The image shown in A is marked to measure motor nerve length.  
Three motor nerves (exit points marked with asterisks) were measured, with the third marked with a yellow line.  (D) Results window for 
three motor nerve measurements.  Mean, Min, and Max report fluorescence intensity.  Length and angle are line-specific features that 
represent useful data for analysis.  The first two results are for lines not represented in the image, as they disappear when new lines are 
drawn. 
 
have required bench work, which was not possible in the 
remote setting.  To mitigate disappointment and promote 
feasibility and success, students worked with the instructor 
to tailor similar but testable questions. 
     Below are some of the questions that students asked: 
 

In what ways is the PLLn mispatterned in mutants? 
What fraction of mutants exhibit stalled PLLn vs. 
incorrect extension? 
How far does the PLLn deviate from its expected 
position in mutants? 
Where do melanocytes aberrantly migrate in mutants? 
How does motor nerve extension differ in mutants?  
To what extent are motor nerves defasciculated in 
mutants? 
Do the above phenotypes improve, or worsen, across 
developmental timepoints? 

 
Additionally, the dataset permitted additional analysis the 
students did not pursue (in some cases, they developed the 
question but ran out of time to test it): 

 
Do glial cells migrate differently from axons in mutants? 
Are muscle segments abnormally patterned in 
mutants? 
Is length of animal and/or head size normal in mutants? 
Are there fewer axons or glial cells in mutants? 

Student Observations and Outcomes 
Because students did not know a priori which samples were 
siblings or mutants, they developed skills in observation that 
resulted in the discovery and characterization of novel 
phenotypes.  They created detailed quantification 
phenotypes (e.g.  numbers of mispatterned melanocytes, 
distance of PLLn from horizontal myoseptum) and 
developed measurement and analysis techniques to 
accurately convey the phenotypes they observed.  In one 
case, a student tried three different techniques to quantify 
motor nerve defasciculation (counting branches, measuring 
area, and analyzing plot intensity profiles) to determine 
which approach best reflected the observed defects. 
     Though the learning curve to understand zebrafish 
anatomy and genetics was steep, students responded 
positively to the opportunity to make independent 
discoveries, especially when they validated their lecture 
course experiences.  As an example, several students 
remarked that they were delighted to realize they had 
identified mutants in a proportion predicted by Mendelian 
inheritance, reflective of the genetics lessons in their 
introductory biology courses.  They were excited to see that 
basic biological principles were reflected in their own 
research and could serve as the foundation for more 
complex hypotheses.   
     All students who participated in this project indicated an 
interest in potentially majoring in neuroscience when they 
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selected a project mentor and research area.  However, they 
were all novices to studying neuroscience at the collegiate 
level, and the introductory biology courses generally do not 
teach neuroscience principles.  Therefore, this research 
experience allowed these novice neuroscientists to explore 
research while learning the details “on the fly” – reminiscent 
of how graduate students often tackle a new area of 
research in laboratory rotations.  Because the students had 
varying backgrounds of neuroscience education and 
exposure, they were encouraged to exercise metacognitive 
skills to identify their gaps in knowledge and independently 
find answers to their questions using the literature as well as 
through discussions with each other and their instructor.  
Additionally, because this study focused on nervous system 
architecture rather than function, basic comparisons of 
patterning between wild-type and mutants were relatively 
straightforward for novice students. 
     The ability to assay a central image database while 
working remotely provided a reasonable balance of 
independence and shared experience.  Several students 
independently chose to pursue similar research questions; 
however, they answered their questions in different ways, 
based on how they saw the phenotype in the image.  They 
were also able to compare notes on identification of mutants; 
one partner pair chose to separately assign samples as wild-
type or mutant, then bring their notes together to determine 
a “final” assignment.  Though students generally had 
consistent findings (a testament to their observation abilities 
and knowledge), it was useful for them to note that the same 
phenotypes could be validly scored in different ways. 
     To promote collegiality and collaboration among remote 
students, the instructor facilitated a group meeting with all 
remote students to discuss their research questions and 
strategies.  This meeting revealed common issues across 
groups, such as software difficulties and concerns with 
mutant identification.  In addition to being an efficient use of 
time, as issues were resolved together rather than 
individually, the students were able to develop a sense of 
camaraderie and agency in troubleshooting each other’s 
questions.  More meetings would likely have been 
beneficial, though scheduling was too difficult.   
     Some challenges for remote students were 
insurmountable.  Students sometimes felt isolated without 
easy or quick solutions to their issues.  Troubleshooting with 
Fiji and R programming was particularly difficult, and 
students lacked access to other computers (e.g.  their 
research partner’s, a computer lab) that they would have 
had on campus.  Most technical problems, however, were 
overcome with additional time and effort. 
     When developing their projects, several students noted 
that they wished they had the opportunity to test some of 
their predictions in person, like testing a drug treatment of a 
candidate pathway or testing expression of candidate 
genes.  This is not strictly a limitation of the remote aspect 
of the research; vertebrate animal approval and training 
would likely take up a large part of the project period and 
yield less useful data. 
 
Opportunities for Modification or Extension 
Because image analysis can be done entirely on a 

computer, this lab module was well-suited for remote 
projects.  On-campus students could, however, complete 
similar projects by first learning how to use the microscope 
to image samples themselves.  While creation of a full image 
dataset would likely not be possible with novice 
microscopists, students would learn the importance of 
imaging parameters, including specimen orientation, 
magnification, and camera exposure.  Students would also 
appreciate the amount of time that goes into collecting 
images for a statistically useful sample number.  Finally, 
including students in image collection would allow an 
additional dimension to experimental design, as students 
could selectively monitor their feature of interest, rather than 
using a “one size fits all” image collection. 
     Because this was a capstone project for a year-long lab 
course, students had already developed skills in 
experimental design, observation, and statistical analysis.  If 
students do not already possess those skills, image analysis 
offers attractive opportunities to teach all three in an 
expanded module.  Students can learn to identify control 
and experimental groups and apply the appropriate 
statistical tests via images alone.  Additionally, observational 
techniques can be superbly taught with image samples.  
Instructors can develop guided questions and discussion 
that allow students to identify meaningful landmarks during 
zebrafish development. 
     This pilot used a novel mutant in the instructor’s lab; in 
addition to the mutant discussed here, instructors can 
develop projects related to their own area of expertise.  This 
provides a superb mechanism by which teaching-research 
faculty can work with students to generate data that leads to 
publication with student authors.  Alternatively, instructors 
can use existing developmental mutants with different 
fluorescent transgenic reporters to create a novel 
exploration for students.  For instance, sox10/colorless 
mutants have broad mispatterning of neurons, glia, and 
pigment cells (Dutton et al., 2001), and there are a wealth of 
markers for neurons and glia (Förster et al., 2017).  This can 
become an attractive opportunity for an instructor to 
synergize teaching and research or build a full course-based 
undergraduate research experience (CURE).  Using 
established mutants, however, might interfere with true 
inquiry and developing novel questions.  It also may 
necessitate crossing fluorescent transgenes into mutants, 
which can be time-consuming for an instructor. 
     Instead of mutants, instructors may consider perturbing 
nervous system development and structure via varying 
concentrations of small molecule compounds (Zon and 
Peterson, 2005).  For instance, ethanol and lithium chloride 
are relatively inexpensive compounds that produce nervous 
system patterning defects (Ross and Bonner, 2012; Facciol 
et al., 2019).  Drug treatments are an especially useful 
alternative for instructors unable to house multiple mutant 
strains, as only a single strain carrying transgenic reporter 
genes is needed.  Additionally, drugs can be easily applied 
in combination to test the interplay of multiple factors.  The 
major limitation, therefore, becomes the time to build an 
image collection.   
     Given the relative ease of using zebrafish in the 
classroom relative to other vertebrate models, students may 
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be incorporated into the steps involving zebrafish breeding 
and raising embryos to the relevant embryonic/larval stage.  
This gives students additional control in their experimental 
design and parameters to pursue.  This would be a 
particularly attractive option for instructors expanding this 
module into a full course, as well as for courses with upper-
level (rather than beginning) students that are studying on 
campus.  Instructors are cautioned to follow institutional 
animal protocols (IACUC) to ensure that students may 
handle zebrafish adults and larvae. 
     Fiji and R/RStudio are freely available software that are 
often used in laboratories at research institutions, so gaining 
proficiency at the undergraduate level sets up future 
researchers for success.  Instructors can build image 
analysis related to their area of research into courses.  
Zebrafish researchers can use in situ hybridization or 
immunostaining images (Cunningham and Monk, 2018); cell 
culture and other model systems could be used as well.  
Instructors who want to teach these skills, but lack animal 
research or microscopy, can take advantage of freely 
available repositories (e.g., Gigapan at 
https://gigapan.com/, Allen Brain Atlas at https://portal.brain-
map.org/) or natural history collections to teach Fiji-based 
image analysis to undergraduate students.  Use of selected 
images could also allow a focused image analysis module 
over a shorter period of time, e.g., 2-3 weeks instead of 7-8, 
particularly if students are not developing independent 
questions. 
 
SUMMARY 
Image analysis is a useful skill for undergraduates to 
develop in introductory laboratories.  Zebrafish larvae are 
particularly attractive subjects for image analysis, as 
established transgenic reporters marking neurons and glia 
can be readily imaged at multiple developmental timepoints 
in living animals.  Instructors can collect images in a single 
repository that multiple students can use to develop 
independent questions of interest.  The data students collect 
can be quite robust and amenable to basic statistical tests 
and data visualizations.  Importantly, the entire module can 
run with students in a remote setting, with free software and 
remote guidance from the instructor. 
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