GENEIOUS DETAILED WORKFLOW FOR THE ANALYSIS OF CELL-FREE DNA
LIBRARIES SUBJECTED TO TARGETED HYBRIDIZATION CAPTURE USING
PERSONALIZED BIOTINYLATED BAITS AND NGS

1. Import Fast Q files into Geneious.

1.1. Drag FastQ files into Geneious or

1.2. Go to File > Import > From File

1.3. Set the two sequence lists (_ R1 and _R2) as paired reads. Go to Sequence > Set Paired
Reads. Set expected distance/insert size to 300 bp. Delete the two original FastQ files

1.4. Set up Reference

1.5. Download Human Reference Genome and import it into Geneious (e.g.
http://support.illumina.com/sequencing/sequencing software/igenome.html)

1.6. Label targeted positions (e.g. those genomic positions mutated in the primary tumors) as
“Somatic Mutations”. Select a base or group of bases in the reference and then click on the
“Add Annotation” button.

Go to a specific position
Go to a specific chromosome / /
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1.7. Go to Tools > Extract Annotations and use the following settings:

| Extract Annotations
@ Match all of the following Match any of the following
Annotation type v!|Is v | Somatic Mutations v g ==
What to extract: | Annotated Region v
Intersecting Annotations: | Indude All v

Concatenate regions within each sequence

D Indude Intergenic Regions
¥ Extraction Context
Include upstream (5 flanking bases: 1,000 |5+
Indude downstream (3) flanking bases: | 1,00045

Cancel

X


http://support.illumina.com/sequencing/sequencing_software/igenome.html

1.7. Select all extractions (Ctrl+A) and then go to Tools>Concatenate Sequences or Alignments.
Add 500 bp spacers between loci. Do not circularize sequences.

1.8. If selected loci display high sequence complexity (there are no other regions of the genome
with >90% sequence similarity) the reference is finished. Otherwise, similar loci must be
included in the reference to avoid mapping artifacts. Running local MegaBLAST in Geneious
or other platforms (i.e. UCSC Blat tool, https://genome.ucsc.edu/cgi-
bin/hgBlat?command=start) can help ascertaining weather loci are composed of unique
sequences or if similar loci (i.e. paralogs, pseudogenes etc.) exist. If so, extract those loci
and concatenate them into the reference. Use the % Pairwise Identity and the Query
Coverage Scores, which should be <90%.

2. Select reference and list of paired reads and go to Workflows > cfDNA-GenWkf1

¥ Edit Workflow Ed

Workflow Name: |cfDNA-GenWwf1 |

Description:

Icon: |[}’ vH Choose Custom Icon...

‘ [] Share {read-only) with other Shared Database users

oh Add Step == Delete Step / View[Edit Options ? Help

O Group Documents
Align/assemble -> Map to Reference Options: '
Merge Paired Reads Options: Merge Rate=High

Filter Documents Options: Apply to=Each document Name Does not contain 'Unmerged"

-» De Novo Options: Assembler Version="9.1.3; "

Filter Documents Options: # Source Sequences = '2'

Rename Document(s) Options: Collapsed Reads + Current Mame

Trim Ends Options: Trim regions...; bp=17; bp=17

Save Documents  Branch Options: Save. Branch with output from & operations ago

Workflows - cfDNA-GenwWkf2

p Filter Documents Options: Apply to=Fach document Name Contains 'Unmerged'

El




*Customizable options for the Align/Assemble — Map to Reference step of the workflow

Edit Align/Assemble -> Map to Reference

Align sequences or reads to a reference. Can be used for re-assembly, variant finding, locating a sub-sequence etc

Options to expose to user when workflow is run
(@) Expase no options

() Expose all options

() Expose some options

Optionally label exposed options as: ‘

Expose: ‘data.ReFerence Sequence:

All Operation Options (those not exposed to worlflow user and default values for options that are exposed)

Data
[] Dissolve contigs and re-assemble
Reference Sequence: ‘Autcmah'c w ‘ ‘ Choose... | E
[[] Assemble by: El part of name, separated by
[] Assemble each sequence list separately
Method

Mapper: | Geneious

B[k
E— 2

[ Find structural variants and deletions of any size | |

[]Find large deletions up to 1,000 3 | bp

Fine Tuning: |None (fast / read mapping) W | m

Memory Required: 1.0 GB of 26 GB

Note: Paired reads can be 0 or changed

g Sequence > Set Paired Reads

Trim Before Mapping Results

With Alternative Label: l:l g - - -

8 ?
® © ?
BackUp Support Help
=nces % Pairwise I... Bit-Score E Value Desaription
99.8% - - 18,636 read:
98.5% - - Assembly of
Access exposed options via button E - - - 1-CTG
= 2-TCA
- 3-AGT
' ' ' ]
7 Trim Options
@ Annotate new trimmed regions (ignored by assembt
() Remave new trimmed regions from sequences
[] Trim vectors: ‘Un\\dec (High sensitivity) (will be autom:

Minimum BLAST alignment score:

[] Trim primers:

| Allow Mismatches: 5E

Minimum Match Length: 52

(decrease to trim mar

Trim regions with more than 3 5% chance of anen

[[] Errar Probability Limit:

Assembly Name ‘{Raads Name} assembled to {Reference Name}

| [

Save assembly report
() Use existing trim regions d

Save list of unused reads
(") Remove existing trim regions from sequences d

Save list of used reads Indude mates

(®) Re-trim sequences

[[] Save in sub-folder

[] Maximum low quality bases: _
[[] Maximum ambiguities: n

[w] Trim 5" End Atleast bp
[#] Trim 3' End Atleast bp

[] Maximum length after trim: 1,000 % | (Trim excess from 3' e

[] Minimum mapping quality: 305

Trim paired read overhangs

Map multiple best matches: |Randomly
[] only map paired reads which

Minimum support for structural variant discovery:

Allow Gaps  Maximum Per Read

Maximum Gap Size:
[ Minimum Owverlap:

Word Length: Index Word Length:
Ignore words repeated more than

Maximum Mismatches Per Read:

Maximum Ambiguity:

[[] Accurately map reads with errors to repeat regions [] Search more thoroughly for poor matching reads

£ Fewer Options | ‘ Reset to Defaults

o n e e

Reset to Defaults

f— FE—— [¥] Lock annot;
e e——————————— [[] Compress z
— [] Show arrov
— [+/] Hide exces:
—
B T e b Sizes
==
OK Cancel —_—
—_——— -




*Customizable options for the De Novo Assemble step of the workflow

Edit Align/Assemble -> De Novo Assemble

Assemble reads (eg. Sanger or NGS) without using a reference

Dptions to expose ko user when workflow is run

Expose no options

@ o ?

Back Up Support Help

‘:] Expose all options nces % Pairwise ...  Bit-Score E Value Desaription
_ . 99.8% - - 18,636 reac
(_) Expose some options 98.5% - - Assembly of
: : . ) D - - - 1-CT6
Optionally label exposed options as: Access exposed options via button |7 meTTE
Expose: |data.customComponenti With Alternative Label: = = - - - 3-AGT
- - - Sequence:
All Operation Options (those not exposed to workFlow user and deFault values For options that are exposad) - N N -
Data 94. 7% - - Assembly of
Dissolve contigs and re-assemble 2255 - - Assembly of
95.3% - - Assembly of
[] Assemble by: | 1st part of name, separated by |- (Hyphen) 95.9% = = Assembly of
Assemble each sequence list separately .
o Consensus Options H
[Juse 100 % | % of data. Suitable for genome size between 0 KB and 0 KB
() Save consensus used by assembler
Method
Generate new consensus from contig
Assembler; | Geneious v|[?
Threshold: | 0% - Majority W ?
Sensitivity: | Custom Sensitivity v|[? Threshold for sequences without quality: | 75%

Trim Before Assembly

() Use existing trim regions

(:) Remove existing trim regions from sequences

() Re-trim sequences

Memory Required: 84 MB of 26 GB

o Sequence > Set Paired Reads

Results

Assembly Name |{Reads Name} Assembly

[] save assembly report
[] save list of unused reads

[] save in sub-folder

[] Ignore Gaps
Assign Quality Total w
Ifno coverage call |-  w

if |Coverage < 215

[eal |2

[] spiit into separate sequences around '?' calls

Sris Reset to Defaults Cancel
e =1y
Do not trim (discard trim annotations) []save contigs (! Maximum 1,000 =) )
Save consensus sequences Options (modified) o e
Mumbering
[—— [] Mini-map
A o ————

[] Don't merge variants with coverage over approximately 65| [¥]Merge homopolymer variants —_— Show sequ
e e e — [ Qutline ba

[[] Produce scaffolds [ Circularize contigs with matching ends —
- . . - —_ Annotati

Allow Gaps ~ Maximum Per Read: 105 % Maximum Gap Size: 1= e e . N

= Labels: | Inside
Minimum Overlap: 05 Minimum Cverlap Identity: Rl I — Overlay wl

[=——]
Word Length: 125 Index Word Length: 1205 — — i — ——— Lock annot
gnore words repeated more than 100 5| times Reanalyze threshold: 1615 — L] Compress
[] Show arrer
Maximum Mismatches Per Read: 14 % Maximum Ambiguity: L1 - = — Hide exces

Only use paired hits during assembl — —

Low Memory Use Speed LEEs < 4 b Sizes
1 5

4% Fewer Options Reset to Defaults

Cancel

*Word Length and Index Word Length are the parameters that may stronger influence the speed of this

operation.



cfDNA-GeniWkf2

Icon: |fj v|| Choase Custom Icon...

i [] share {read-only) with ather Shared Database users

gk Add Step == Delete Step #* View/Edit Options

Workflows - Trim and Filter Options: Error probability...=0.001; Trim regions. .. Post-Trim > '75'

Set Paired Reads Options: Detach existing...

Align/Assemble -> De Movo Assemble Cptions: '

Rename Document(s) Options: Collapsed Reads + Current Mame

Filter Documents  Options: # Source Sequences = '2' + Sequence Length "160°

Trim Ends Options; Trim regions...; bp=17; bp=2




*Customizable options for the De Novo Assemble step of the workflow

Edit Align/Assemble -> De Novo Assemble

Assemble reads (eg. Sanger or NGS) without using a reference

Options ko expose ko user when workFlow is run

(®) Expose no options

® © :

BackUp Support Help

E:) Expose all options nces % Pairwise [... Bit-Score E Value Description
. 99.8% - - 18,636 reads |
[_) Expose some options 98.5%, - - Assembly of 2
Optionally label exposed options as: Access exposed options via button [P - - - ; - gﬁ
Expose: |data.customComponent1 With Alternative Label; - - - - 3-AGT
- - - Sequences f
All Operation Options (those not exposed to workflow user and default values For options that are exposed) - t - t
Data 94.7% - - Assembly of 2
[] Dissalve contigs and re-assemble B - - Assembly of 3
95,3% - - Assembly of 2
Assemble by: | 1st part of name, separated by |- (Hyphen) 95.9% = = Assembly of 2
Assemble each sequence list separately - - - -
Use 100 5 | % of data. Suitsble for genome size between 0 KB and 0 KB. - . - Paired reads o
Method - - - -
99,2% - - 447,766 reads
Assembler: | Geneious v|[? - - - -
Sensitivity: | Custom Sensitivity v| [P g Consensus Options “
Memory Required: 84 MB of 26 GB (") Save consensus used by assembler
‘sired reads can be set up or changed using Sequence > Set Paired Reads @J Generate new consensus from contig
Trim Before Assembly Results

Assembly Name |{Reads Name} Assembly

(:J Use existing trim regions D Save assembly report

() Remove exdsting trim regions from sequences [ ] 5ave list of unused reads

() Re-rim sequences Options [[]save in sub-folder
(®) Do not trim (discard trim annotations) [[]Save contigs (¥ Maximum 1,000 <)
Save consensus sequences Options (modified)
[]Don't merge variants with coverage over approximately 6 | [#] Merge homopolymer variants
[] Produce scaffolds [[] Circularize contigs with matching ends
Allow Gaps ~ Maximum Per Read: 1015 % Maximum Gap Size: 1
Minimum Overlap: 1475 Minimum Overlap Identity: 99t
Word Length: 1205 Index Word Length: 1205
Ignore words repeated more than 100 5] times Reanalyze threshold: 1615
Maximum Mismatches Per Read: 1% Maximum Ambiguity: 4

Only use paired hits during assembl
Low Memory Use Speed Ll only Pe < v
1 2 3 4 5

4% Fewer Options Reset to Defaults

Threshold: | 0% - Majority w|[?

Threshold for sequences without quality: [75%

[] Ignore Gaps

Assign Quality |Total  w
Ifno coverage call |- v

if |Coverage < 25

ecal |2

[] Split into separate sequences around '?' calls

Reset to Defaults Cancel

T ——— = T —— [ Outline base:
——— e — — —

- T — Labels: | Inside
—_— Overiay wher
— — i — ——— | Lock tat

ock anno
e [] Compress an
— [ Show arrow |

Hide excessi

b Sizes

*Word Length and Index Word Length are the parameters that may stronger influence the speed of this
operation.



3. Select the two lists of collapsed reads generated by the two previous workflows (i.e. GenWkf1 +
GenWkf2) and the reference sequence and go to Workflows > cfDNA GenWkf3

g Edit Workflow [ x|
Workflow Name: | cfDNA-GenWkf3 |
Description:
Icon: | Cr

v | | Choose Custom Icon...

‘ [] Share (read-only) with other Shared Database users

4k AddStep == Delete Step ## View/Edit Options 2 Help

=2 Align/Assemble -> Map to Reference  Options: '

g Find Variations/SNPs Options: 'Somatic Mutations'; CDS Properties... ='gene, product...'

g Edit Align/Assemble -> Map to Reference -
) LApUSE an upuuns N
() Expose some options

Optionally label exposed options as: | Accesg exposed options via button IZI
Expose: ‘data.Reference Sequence: With Alternative Label: l:l L -
All Operation Options (those not exposed to worlflow user and default values For options that are exposed)
Data
[] Dissolve contigs and re-assemble
Reference Sequence: |aumman‘c W || Choose. .. ‘ E‘
mble by: part of name, separaf y |- (Hyphen
Assemble b tof ted b h
[] Assemble each sequence list separately
Method
Mapper: ‘Geneious W | |Z|
Sensitivity: |Custom Sensitvity v|[7]
ind structural variants and deletions of any size
Find structural variants and deleti f i
[] Find large deletions up to 1,000 5 |bp
Fine Tuning: |Nona (fast [ read mapping) v | IE
Memory Required: 1.0 GB of 25 GB
Notz: Paired resds can be set up or changed using Sequence > Sef Paired Reads
Trim Before Mapping Results
Assembly Name
Save assembly report
(®) Use existing trim regions o
Save list of unused reads
O Remove existing trim regions from sequences D
[7] save list of used reads Indude mates
O Re-trim sequences Options
[] 5ave in sub-folder
() Do not trim (discard trim annotations) S ErTEs
[] 5ave consensus sequences Options
v
Advanced ~
[] Minimum mapping quality: Map multiple best matches:
Trim paired read overhangs ["] only map paired reads which
Minimum support for structural variant discovery
Allow Gaps Maximum Per Read: Maximum Gap Size
[] Minimum Overlap: [ Minimum Overlap Identity: %
Word Length: Index Word Length:
Ignore words repeated more than
Maximum Mismatches Per Read: [ EI % Maximum Ambiguity: 4&'
£ Fewer Options. Reset to Defaults II'




*Customizable options for the Find Variations/SNPs step of the workflow

g Edit Find Variations/SMPs “

Find variations such as SNPs and IMDELs in nudeotide alignments and contigs

Options to expose to user when worlkflow is run
(®) Expose no options

() Expose all options

() Expose some options

Optionally label exposed options as: | Access exposed options via button III

Expose: |Calculate Variant P-values With Alternative Label: | | L

All Operation Options (those not exposed to warkflow user and default values For options that are exposed)
Find Polymorphisms

[ Minimum Coverage: 1=

|:| Minimum Variant Frequency:

[ Maximum Variant P-value: 10 ~ 3 Z| {0.1%% to see variant by chance) III

[ Minimum Strand-Bias P-value: 10 -5 z| when exceeding % bias IZI
Find Polymorphisms | Inside & Qutside CDS  w

In selected region only

Analyze Effects on Translations

[] Analyze effect of polymorphisms on translations

Default Genetic Code: |Standard

[] Calculate Variant P-values

Assumed quality of bases without quality: {99.0%: correct)
P-value calculation method: | Approximate
Homopolymer quality reduction for 454 / Ion Torrent: L ?

[] ©nly Find SMPs &
Merge adjacent variations

[] Ignore reference sequence {only find variations within the sample)

[ Excude paired reads over
Use separate annotations for each variant at a position

[ 1gnore reads mapped to multiple locations

%% from their expected distance

[[] Don't find variations in annotation types: |C0\-'erage - High |

Only find variations in annotation types: |Somaﬁc Mutations |

Also find variations within

DS Properties to Copy: |gene, product, protein_id, locus_tag, note, gene_name, Chr |

ﬁ Fewer Options Reset to Defaults




4. Visually inspect for duplex support for ctDNA at a given position. Sort out contigs by the base at a
given position to help visualization. Go to the selected base, right-click and select Sort by Bases in
column XXX. Be sure to turn off the “Vertically compress contig” option in the advanced menu (right

] Geneious 9.1.5 - For non-commercial use only - o lENE
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This example shows three ssDNA molecules supporting ctDNA; two of the ssDNA molecules belong to
the same duplex as they show different strand-specific tags, map against the reference in different
orientations but share the same mapping coordinates and show one single adapter annealing mispairing
across the 24-nt semi-degenerate barcodes (see figure below).
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The workflows that analyse sequencing data from enrichment experiments with large gene panels rely on
essentially the same algorithms but incorporate a few important modifications. First, there is no minimum number
of reads to generate any consensus sequences and non-assembled reads are retained except those filtered out due
to low quality. Second, variant calls are not restricted to specific sites and we searched for non-reference alleles
across coding regions and splice donor/acceptor sites. The workflows mentioned above can be downloaded



directly from the supplemental material that accompanies this paper. Workflows intended to work on large
captured regions have the suffix -lp added to the names of the three main workflows described above.



