
 

 

 

Figure S1. (A) Comparison of 16 months old fish zebrafish circadian rhythm pattern; the 

locomotion was analyzed by either idTracker (blue color) or ImageJ (red color) methods. The data 

are expressed as the means. Comparison of idTracker and ImageJ results after data normalization 

for 16 months old fish in (B) light and (C) dark cycle with r value from Spearman nonparametric 

correlation test. The data are expressed as the means ± SEM and were analyzed by unpaired t-test 

with Welch’s correction (n =18). Comparison of total (D) average speed, (E) average angular 

velocity, and (F) meandering of zebrafish between the light and dark cycles. The data are expressed 

as the means ± SEM (n=17) and were analyzed by unpaired t-test. Comparison of total (G) average 

speed, (H) average angular velocity, and (I) meandering of catfish between the light and dark 

cycles. The data are expressed as the means ± SEM (n=6) and were analyzed by Mann-Whitney 

test. Significance difference was defined as **P < 0.01, ****P < 0.0001. 
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Figure S2. Comparison of zebrafish circadian rhythm activities for fish acclimated to (A) 18°C or 

(B) 30°C temperature and the locomotion was analyzed by either idTracker (blue color) or ImageJ 

(red color). The data are expressed as the means. Comparison of idTracker and ImageJ results after 

data normalization for 18°C acclimated fish in (C) light and (D) dark cycle and 30°C acclimated 

fish in (E) light and (F) dark cycle with r value (highlighted in blue color) from Spearman 

nonparametric correlation test. The data are expressed as the means ± SEM and were analyzed by 

unpaired t-test with Welch’s correction (n =13 for 18°C temperature group and n=18 for 30°C 

temperature group). 
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Figure S3. Comparison of zebrafish circadian rhythm activities for fish acutely (A) andchronically 

(B) exposed to 0.1% EtOH and the locomotion was analyzed by either idTracker (blue color) or 

ImageJ (red color). The data are expressed as the means. Comparison of idTracker and ImageJ 

results after data normalization for acutely 0.1% EtOH exposed fish in light (C) and dark (D) cycle 

and chronically 0.1% EtOH exposed fish in light (E) and dark (F) cycle with r value (highlighted 

in blue color) from Spearman nonparametric correlation test. The data are expressed as the means 

± SEM and were analyzed by unpaired t-test with Welch’s correction (n =18 for acute and chronic 

exposure of 0.1% EtOH groups). 
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References Age of 

Zebrafish 

Light Source Recording Apparatus Recording Quality Data Analysis Data output 

Cahill et al. 

(1998) [1] & 

Hurd et al. 

(2002) [2] 

Larvae Infrared (>700 

nm) illumination 

CCD camera with a 28 mm 

lens, automatic gain control 

and shading correction 

(Hamamatsu Photonics, 

Hamamatsu, 

+F2+D2:H+D2:I2 

Monochrome 

images  

(640 x 480 pixels, 

8 bit resolution) 

Optimas (Seattle, WA) image 

analysis software controlled by 

a macro written in Analytical 

Language for Images & Chrono 

II software (T. Roenneberg, 

University of Munich) 

Actogram 

plots 

Hirayama et al. 

(2005) [3] 

Larvae A custom made 

diffuse axial 

illuminator with 

infrared light 

source 

Monochrome video camera 

with a 50-mm macro lens, 

and a 1.7-cm CCD sensor 

with the IR-blocking filter 

removed, automatic gain 

control, shading correction 

and horizontal center 

resolution >750 TVL; a 

desktop computer with a 

640x480 pixel, 8-bit gray 

scale frame capture card 

(Flashpoint 128), and a 

Windows operating system 

Not mentioned in 

the original article 

Optimate 6.2 

(MediaCybernetics, Silver 

Spring, MD) image processing 

software with the Swimming1.1 

macro (Meyer Instruments, 

Houston, TX) and Chrono 4.5.1 

Actogram 

plots 

Prober et al. 

(2006) [4] 

Larvae Zebrabox 

(ViewPoint Life 

Sciences) 

An automated video-tracking 

system (Videotrack; 

ViewPoint Life Sciences, 

Montreal, Quebec, Canada) 

with a Dinion one-third inch 

Monochrome camera (model 

LTC0385; Bosch, Fairport, 

NY) fitted with a fixed-angle 

megapixel lens (M5018-MP; 

Computar) and infrared filter 

Not mentioned in 

the original article 

Custom PERL software and 

Visual Basic Macros for 

Microsoft (Seattle, WA) Excel 

Activity plots 

and 4 

behavioral 

endpoints 

Table S1
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Zhdanova et al. 

(2008) [5] 

Adult Male Illuminated floor 

and an additional 

light source 

placed next to the 

tanks 

One camera & automatic 

animal tracking software 

(Video-track, View Point Inc, 

France) 

30 fps video Nonlinear least squares analysis 

(Mathematica, Wolfram 

Research, Champaign, IL) 

4 behavioral 

endpoints 

Lopez-Olmeda  

et al. (2009) [6] 

Adult Fluorescent bulb 

(F15W/GRO. 

Sylvania Gro-

Lux, Germany) 

with 400 lux light 

intensity 

Infrared photocell (Omron, 

mod E3S-AD62, Kyoto, 

Japan 

No video  

(light-beam 

interruptions) 

Chronobiology software El 

Temps© (version 1.228; Prof. 

Diez-Noguera, University of 

Barcelona) and SPSS® 

software 

Actogram 

plots 

This Study (2018) Adult White COB LED 

and 940 nm IR 

LED beneath the 

fish tanks 

940 nm infrared CCD 

camera, workstation 

computer with 1 TB SSD  

and Intel Core i7-6850K 

CPU, and Total Recorder 

software 

1028x1024  

30 fps video 

Image-J image analysis 

software, idTracker software, 

and Microsoft Excel 

Average 

speed and 

meandering 

plots and 6 

behavioral 

endpoints 
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Required Programs summarized

• ImageJ

• idTracker

• Microsoft Excel• Total Recorder

• Matlab Compiler Runtime

Method 1 : Establish idTracker-based method to measure circadian rhythm in fish

Supplementary protocol
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Methods

Set the Video 
Recording and 
Light Schedule

idTracker
Parameters 
Adjustment

Movement 
Tracking

Data 
Analysis
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Tips for Video Recording

• Frame rate per second (FPS)
• ↑ : more accurate tracking, slower process

• ↓ : less accurate tracking, faster process

• Use a good contrast vessel for the fishes
• Using Black and White image setting is recommended because it can

enhance the contrast
• There must be free space in the disk because tracker will generate a

large amount of data
• Internal hard drive’s video usage is strongly recommended
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Example Video (Zebrafish)

1280x1024; 30fps *original video is available upon request

Day Cycle Night Cycle
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Parameters Adjustments

Execute idTracker.exe

Select video file

Load the video
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1. Enter the number of individuals
2. Intensity threshold

• The system is going to considers that pixels with
lower intensity than this threshold belong to the
animals (vice versa if “invert contrast” is checked)

3. Minimum size
• The programs will reject blobs

smaller than the minimum size
entered
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4. Choose resolution reduction
• If the sizes of the animals are bigger than

2000 pixels, input a number higher than 1
(the number of pixels will be divided by n2,
where n is the number in the box)

5. Background removal option
• Check if you want to activate the

background removal option
• To compute it before, click on the

‘Compute Bckgrnd’ button
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6. Choose an interval
• If you want to track only part of video,

enter the interval that you want to track

7. Number of references frames
• Choose a lower number for increased

speed, a higher number for increased
accuracy
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8. Select Region Of Interest (ROI)
and/or exclude regions
• Click on button ‘Clear’ to clear all

previously defined ROS’s or excluded
regions

9. Segmentation only
• If this box is checked, idTracker will exit after

the segmentation step, leaving the tracking
unfinished.

• The data can be recovered later using button
‘Load Previous Data’
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10. Number of processors
• The number of this box indicates how

many processors idTracker will use (‘Inf’
means that idTracker will use all
available processors)

11. Start tracking
• Click the ‘Start’ button
• If ‘S&E’ (Save & Exit) button pressed, the

programs ends, but the tracking does not start.
All tracking parameters can be used later using
‘Load Previous Data’ button
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Movement Tracking

Separated tracking

• Advantages
• Reduce error occurrence
• Tracking duration takes less time

• Disadvantages
• Need more space to store the video

• Advantages
• Just one video needs to be saved

• Disadvantages
• Error often occurred
• Tracking duration takes more time

√ X
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Results
• The results are in a

folder called ‘segm’
located in the same
folder as the video

• Press ‘About the
output files’ for more
information about the
results

• ‘See results’ button
will play the result’s
video
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Tracking Result’s Video
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Results
• There will be four output files

• Two of them are .mat files, to
be loaded into Matlab

• The other two are .txt files to
import the data into any
software

• Both of the files contain
identical information, which is
the following
• X and Y coordinates of each

individual in each frame
• Probability of correct

assignment
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Results
• Difference between

trajectories and
trajectories_nogaps
• The files called ‘trajectories’

contain only the position of
each individual when it is not
occluded

• The files called
‘trajectories_nogaps’ contain
the position of each individual
also when occluded
• The probability of correct

identity contains a negative
number when the position
comes from an estimation
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Results
• Each row corresponds to one frame of the

video
• Columns 1 and 2 are the x and y coordinates

of individual 1, respectively, and so on

• There is an estimation of the probability
of correct assignment for each frame and
it is usually conservative
• The probabilities for individual 1 are in

column 3, for individual 2 in column 6, and so
on
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Results

• Convert the pixel dimension
into the standard length
dimension using ImageJ
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Results (Calculation Example)

• Use the Microsoft Excel’s
formula to calculate the fish’s
movement frame by frame

• Measure the fish’s rate of speed
by dividing the calculation
results with the time
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Some parameters we can get from this idTracker-based method

• Total distance traveled (cm)

Σ (X2−X1)
2+(Y2−Y1)

2+(Z2−Z1)
2

• Avg. swimming speed (cm/s)
𝑻𝒐𝒕𝒂𝒍 𝒅𝒊𝒔𝒕𝒂𝒏𝒄𝒆 (𝒄𝒎)

𝑻𝒐𝒕𝒂𝒍 𝑻𝒊𝒎𝒆 (𝒔)

• Maximum speed (cm/s)

• Minimum speed (cm/s)

• Freezing Time (s)
(Total Time when speed less than 1cm/s)

• Swimming Time (s)
(Total Time when speed 1-10 cm/s)

• Rapid Movement Time (s)
(Total Time when speed more than 10 cm/s)

• Meandering (⁰/m)
(The degree of turning vs. travel distance)

Absolute turn angle (°)
(

Total distance (cm)
× 𝟏𝟎𝟎)
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• Turning Angle (⁰)
𝟏

𝒕𝒂𝒏(
∆𝒀
∆𝑿

) × 𝟏𝟖𝟎

𝝅

• Fast Type Latent Time (s)
(Total time when Angular velocity above 0.5⁰/ms)

• Slow Type Latent Time (s)
(Total time when Angular velocity below 0.5⁰/ms)

• Absolute Turn Angle
(Sum of all the Turning Angles without considering the sign of angular direction)

• Angular Velocity (⁰/ms)

𝑻𝒖𝒓𝒏𝒊𝒏𝒈 𝑨𝒏𝒈𝒍𝒆 × (
𝑽𝒊𝒅𝒆𝒐 𝒅𝒖𝒓𝒂𝒕𝒊𝒐𝒏 (𝒎𝒔)

𝑭𝒓𝒂𝒎𝒆 𝒑𝒆𝒓 𝒔𝒆𝒄𝒐𝒏𝒅
)

Some parameters we can get from this idTracker-based method
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Example of circadian rhythm pattern for zebrafish
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Method 2 : Establish ImageJ-based method to measure circadian rhythm in fish

Required Programs summarized

ImageJ Microsoft ExcelTotal Recorder VirtualDub
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VirtualDub

• VritualDub is open source video capture/processing,
it is designed to process linear video streams,
including filtering and recompression

• The main purpose in this experiment is to convert
from video is to recompress the video
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Change Video Output Format in VirtualDub

Open the VirtualDub software
Video -> Color Depth
Select output format as 8-bit (Grayscale) 
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Open the AVI file in VirtualDub

• File -> Open video file (Ctrl+O)
• Select the video file (.avi format)
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Save the Output of VirtualDub

• File -> Save as AVI (F7)
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ImageJ

• ImageJ is open source Java-based image processing. It can
display, edit, analyse, process, and save images

• The main purpose in this experiment is to analyse the pixel
value change in the video

• This platform supported by many plugins that ease the
analysis
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• Open the VirtualDub file

Open VirtualDub Video in ImageJ
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• Select the interested frames
• Convert the VirtualDub into grayscale (8-

bit)

Convert Video Image Into Greyscale
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• Select the tanks with rectangle selection
• Crop the area: Image -> Crop (Ctrl+Shift+X)

Crop the Interested Area
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• Duplicate the file to ease the analysis
• Image -> Duplicate (Ctrl+Shift+D) ->

Duplicate stack

Duplicate the Video

Biology Open (2019): doi:10.1242/bio.041871: Supplementary information

Jo
ur

na
l o

f 
B

io
lo

gy
 O

pe
n 

• 
S

up
pl

em
en

ta
ry

 in
fo

rm
at

io
n



• Adjust the threshold
Image -> Adjust -> Threshold
(Ctrl+Shift+T)

• Select the dark background

Adjust the Threshold
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• Stack Difference to see the only object
that move (have pixels changed)

• Use stack difference
Plugins -> StackDifference

Use Stack Difference Plugin
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Select the interested area in 
original VirtualDub file

Use the Original Video as Template
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• Click on the duplicated
VirtualDub file

• Restore the selection from
original file
Edit -> Selection -> Restore
Selection (Ctrl+Shift+E)

Restore Selection from the Original Video
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• Use Time Series Analyzer
Plugins -> Time Series Analyzer V3

Use Time Series Analyzer Plugin
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• Use Time Series Analyzer
Add -> Get Average

Get Average of Pixel Intensity Change
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Save the file

Get The Dynamic Pixel Change Data Over Time 
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Record Macro can speed up calculation

• The macro recorded based on the
mouse click

• Plugins -> Macros -> Record
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Record the Features into Macro

ROI must be adjusted when new 
experiment conducted with position 
change
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Create the Macro
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Save the Macro

• File -> Save (Ctrl+S)
• Save the macro as .ijm extension
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Run the Macro

• Plugins -> Macro -> Run
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Select All Regions
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Copy the Result

• Select all the result
• Copy and paste into the excel file
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ImageJ

Programming language based

idTracker

Matlab Java

Endpoint output More representative Only in pixel intensity changes

Occluded fish analysis Hard to analyse Easy to analyse

Built in Macro for Automatization Not Available Available

Analysis time needed (6 tanks, @1 fish) 5’35” 3’(without macro),  2’(with macro)

Analysis time needed (6 tanks, @3 fish) 13” 3’(without macro),  2’(with macro)

Video format supported Many format Only AVI

Size of the fish dependency No Yes

Individual fish tracking Able Not able

Dead fish / noise Can be excluded Possible to be counted

Data storage consumption size 
(24 videos analysis size)

Smaller (~15.5Gb) Bigger (~349Gb)

Trajectories Able Not able

RAM consumption 10 Gb 4 Gb

CPU Usage 75% @3.3GHz 10% @3.3GHz

Comparison of idTracker- and ImageJ-based method to measure circadian rhythm in fish

Biology Open (2019): doi:10.1242/bio.041871: Supplementary information

Jo
ur

na
l o

f
B

io
lo

gy
 O

pe
n 

• 
S

up
pl

em
en

ta
ry

 in
fo

rm
at

io
n



Biology Open (2019): doi:10.1242/bio.041871: Supplementary information

B
io

lo
gy

 O
pe

n 
• 

S
up

pl
em

en
ta

ry
 in

fo
rm

at
io

n

Movie 1. Comparison of circadian locomotion activity between zebrafish and catfish. 
This video is played at 5x faster speed. 

http://movie.biologists.com/video/10.1242/bio.041871/video-1
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Movie 2. Comparison of circadian locomotion activity between younger (6 month old) 
and elder (16 month old) zebrafish. This video is played at 5x faster speed. 

http://movie.biologists.com/video/10.1242/bio.041871/video-2
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Movie 3. Comparison of circadian locomotion activity for zebrafish acclimated at 
different ambient temperature of 18, 25 and 30°C. This video is played at 5x faster 
speed. 

http://movie.biologists.com/video/10.1242/bio.041871/video-3
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Movie 4. Comparison of circadian locomotion activity for zebrafish exposed to 0.1% 
ethanol for 30 min (acute) or one week (chronic). This video is played at 5x faster 
speed. 

http://movie.biologists.com/video/10.1242/bio.041871/video-4



