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I. Printer specification 15 

Supplementary Table 1| Table comparing the system developed in this work with the 16 
reported open-source extrusion bioprinters.  PF127 = Pluronic F127, PAA = polyacrylic 17 
acid, CMC = sodium carboxymethyl cellulose, NaAlg = sodium alginate, PCL = 18 
Polycaprolactone, hiPSCs = Human induced pluripotent stem cells, and ECM = extracellular 19 
matrix.  20 

Ref Hardware 
Geometry 

inputs 

Auxiliary 

tools 
No. of inks tested Geometry 

Applications 

demonstrated 

Hinton et al 

(2015)1 

Piston-based 

extruder with a 

commercial 3D 

printer  

CAD Stage heater 

4 

• NaAlg 

 • Fibrinogen 

• Collagen 

• ECM 

bone, heart, 

vascular-like 

structures 

Freeform 

structure 

Reid et al 

(2016)2 
(bioplotter) - hiPSCs, MCF-12a (dispenser) 

Cell 

aggregates 

Nava et al 

(2017)3 
n/a - 

1 

•  NaAlg 
Line Cell-laden line 

Polley et al 

(2017)4 
 - 

1 

• NaAlg 
Gridline 

Cell-laden 

construct 

Bessler, et al. 

(2019)5 
CAD - 

1 

• NaAlg 

Cylinder and 

rectangle 

scaffolds 

Cell-laden 

structure 

Kahl, et al. 

(2019)6 
CAD - 

2 

• NaAlg 

 • NaAlg -gelatin 

Lattice, 

cylinder and 

pyramid 

scaffolds 

Cell 

proliferation 

Ioannidis, et 

al. (2020)7 
CAD - 

1  

• NaAlg -gelatin 
Line patterns 

Cell 

proliferation 

and 

differentiation 

Krige et al 

(2020)8 
n/a UV 

2 

• Gelma 

 • sodium 

hyaluronate 

Line patterns, 

rocket-shaped 

construct 

Biofilm 

electrode 

Tashman et 

al. (2021)9 
n/a - 

1 

• Collagen 

Microfluidic 

network 

Perfusable 

microfluidic 

network 

Engberg et 

al. (2021)10 
CAD 

Camera, 

HEPA filter 

2 

• collagen 

• lamina 

Rectangular 

Cell-laden 

multimaterial 

structure 

Koch et al 

(2021)11 
CAD 

Syringe 

heater 

3 

 • NaAlg -gelatin 

• silicone  

• PCL 

Line, lattices 

Hybrid 

material lattice 

for 

osteochondral 

applications 

Cadiou et al 

(2021)12 
CAD - 

1 

• Epoxy  
Dog bone 

Composite 

structure with 

improved 

mechanical 

performance 

Leech et al 

(2021)13 
CAD -  

3 

 • Gelatin 

• Chitosan  

• Marmite 

Line grids n/a 

Sanz-Garcia 

et al (2020)14 

Pneumatic 

extruder with a 

commercial 3D 

printer 

CAD 

Syringe 

heater and 

cooler 

2 

• PF127 

• Gelatin- NaAlg 

Concentric 

square, circle, 

pillars, log-

pipe 

Cell-laden 

lattices 

Feinberg, et 

al. (2018) 15–

17 

Piston-based 

extruder with 

existing build 

plate 

CAD - 
1 

• NaAlg 

3D 

constructs, 

full size 

model of the 

human heart 

Patient-

specific 

anatomical 

models 
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Ravi et al. 

(2015)18 

Piston-based 

extruders with 

linear stages  

CAD UV, 

2 

• Toothpaste 

•  Black ink 

Rectangular, 

grid 
n/a 

Xing et al. 

(2017)19 

G-code 

(CAD) 
- 

1 

• PF127-glycerol 

Log-pipe, 

ring scaffod 
n/a 

Fitzsimmon, 

et al.(2018)20 
CAD 

Syringe 

heater 

5 

• Gelatin 

 • GelMA 

• Gelatin- 

hyaluronan 

 • Gelatin-NaAlg 

 • PF127 

Cell-laden 

line pattern, 

3D constructs 

(cube, 

cylinder and 

star), 

Constructs 

with channels 

HUVEC 

culture in 

channels 

Yenilmez, et 

al. (2019)21 

Picture, 

CAD 

UV module, 

coaxial 

printhead 

1 

• NaAlg 

Cell-laden 

grid scaffold 

Cell-laden 

construct 

Zhang et al. 

(2019) 

Pneumatic 

extruder with 

linear stages 

 

n/a Heating 
1 

• Silver 
Line pattern Soft actuation 

Lanaro et al 

(2021)22 
n/a Heating 

2 

• PCL 

 • PF127 

Lattice n/a 

Shen, et al. 

(2021)23 
CAD - 

1 

• NaAlg 

Alginate 

hydrogel with 

concentration 

gradient, a 

femur model 

Cell-laden 

structures, 

structure with 

embedded 

concentration 

gradients 

Peng, et al. 

(2021)24 
CAD 

Digital light 

processing 

(DLP) 

projector 

• Liquid crystal 

elastomer 

• Photocurable 

urethane  

• Silver 

Line, spiral, 

ring, buzz 

patterns, rings 

Soft actuation, 

circuit-

embedding 

architectures, 

strain sensors 

Uzel, et al. 

(2022)25 
n/a 

Line 

profilometer 

3 

• PF127 

• Gelatin 

• Photo-

polymerisable 

urethane-based 

materials 

Line patterns, 

crest motif 

Adaptive 

conformal 

patterning 

Shim et al. 

(2012)26 Pneumatic and 

piston-based 

extruders with 

linear stages  

CAD 
Syringe 

heater  

2 

• PCL 

 • NaAlg 

Letters, 2D 

bone-shaped 

structure 

Porous 

osteochondral 

structure 

Lee et al. 

(2017)27 
CAD 

Syringe 

heater 

3 

• PLGA 

• Hyaluronic acid 

•  HA-alpha-TCP 

Lattice, 

cyliner 

scaffold 

Cell-laden 

hybrid lattice 

Byrne et al. 

(2018)28 

Pneumatic and 

FDM extruders 

with a rotational 

mandrel and 

commercial 3D 

printer 

CAD 

FDM 

extruder 

heater 

2 

• Silicone 

•  Thermoplastic 

elastomer 

Line grids Soft actuation 

Ozbolat, et 

al. (2014)29 

Pneumatic 

extruders and 

commercial 

syringe pump 

with linear stages 

CAD 
Coaxial 

printhead 

2 

• NaAlg 

• Cell spheroid 

Lattice 
Cell 

proliferation 

Spiesz, et al. 

(2019)30 

Commercial 

syringe pump 

with commercial 

3d printer 

Coordinates - 
1 

• NaAlg 
2D patterns 

Spatially-

controlled 

model for 

E.coli bacteria 

culture 

Ghosheh et 

al (2016)31 

Commercial 

syringe pump 

with linear stages 

CAD UV, camera 
1 

• PEGDA 
Line patterns n/a 
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Fortunato et 

al. (2021)32 

Pneumatic 

extruder with a 

robotic arm 

CAD - 
1 

• Pluronic acid 
Line pattern 

Non-planar 

printing 

This work 

Piston-based 

extruders with a 

robotic arm 

*4 

geometry 

input 

options  
 

• Coordinates 

• Equation 

• CAD 

• Picture 

• Stage 

heater 

• Syringe 

heater 

• UV 

• Camera 

*11 

• Hydrogels 

(PF127, CMC, 

NaAlg, gelatin, 

PAA, PEGDA, 

methyacrylate 

hydroxylpropyl 

cellulose, sodium 

hyaluronate) 

• Silicone 

elastomer 

(SE1700) 

• Bioceramic 

hydrogels 

(i.e. NaAlg – 

hydroxyapatite) 

• 3T3 suspension 

*Able to 

construct 

complex 

objects 
 

• Multi-

material 3D 

constructs,  

• 2D 

embedded 

vascular-like 

channels 

• 3D intricate 

objects  

*Multiple 

functions 

apart from 

in-air 

printing 
 

• Multimaterial 

printing 

• Embedded 

printing  

• Liquid 

dispensing 

• Printing with 

variable speed 

• Non-planar 

printing 

• Pick-and-

place 

 

 21 

 22 

 23 

 24 

 25 

 26 

 27 

 28 

Supplementary Figure 1| A summary comparing work reported in this study, and those 29 
reported by existing open-source printer platforms (see above Printer specification for 30 
literature source).  31 

 32 

  33 
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Supplementary Table 2| Specifications of the system developed in this study and the 34 
four commercial 3D extrusion-based bioprinters commonly used in the bioprinting 35 
community. The commercial systems are Allevi 3 33 (denoted as ‡ below), Cellink 36 
BioX34, 35  (†) and Envision TEC 3D Bioplotter Starter Series 36 (*) and GeSim 37 
BioScaffolder BS3.337  (§). It should be noted that, though Printer.HM has a lower 38 
mechanical resolution and a narrower heating range than commercial systems, soft 39 
material printing typically does not require a high temperature ( i.e. > 60 oC), and the 40 
print resolution of extrusion soft material printing is in general > 100 μm. As Printer.HM 41 
is designed for soft material fabrication purpose, the heating range and the mechanical 42 
resolution adopted in Printer.HM are considerably adequate.   43 

 This setup Commercial systems 

Cost 
£0.9k (single printhead system) - £1.9k 
(systems with 4 printheads, syringe and stage 

heaters, UV and camera) 
$10k – 100k 

38
 

Maximum no. of printhead slots 6 printheads for one Arduino board 

• 3 (‡, †) 

• 2 (*) 

• 4 (§) 

Geometry input 

• Coordinates 

• CAD 
• Equations 

• Picture 

• CAD (‡, †, *, §) 

Mechanical resolution of the 
motion system 

• 200 μm 
• 1 μm (‡, †, *) 
• Information not available (§) 

Extruder temperature control • RT – 60 oC 

• 4 oC – 160 oC (‡) 

• 4 oC – 65 oC / 250 oC (†) 

• 30 oC – 250 oC (*) 
• 4 oC – 80 oC / RT – 190 oC or 250 oC (§) 

Printbed temperature control • RT – 60 oC (tested range) 

• RT – 60 oC (‡) 

• 4 – 65 oC (†) 
• Not available (*, §) 

UV power • 365/405 nm 

• Yes (365/405 nm) (‡) 

• Yes (365/405/450/485/520nm) (†) 

• No (*) 
• UV LED (§) 

Extrusion method • Mechanical 
• Pneumatic or mechanical (†, §) 

• Pneumatic (‡, *) 

Compatible cartridge size • 1 ml – 3 ml 

• 5 ml (‡) 

• 3 ml – 10 ml (†) 

• 3 ml – 30 ml (*) 
• 10 ml – 30 ml (§) 

Weight • ~11 kg, 45x45x35 cm (excl. enclosure) 

• 21.8 kg, 47x40x36 cm (‡) 

• 18 kg, 48x44x37 cm (†) 

• 90 kg, 84x62x77 cm (*) 
• Information not available (§) 

 44 

  45 
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II.  Bills of materials  46 

Supplementary Table 3| Part list and the breakdown costs of the printing platform. 47 
The total cost refers to the associated cost of a platform equipped with 4 printheads, 48 
stage and syringe heating systems, a UV module and a camera. * denotes the components 49 
used in the electrical circuit.  50 

 Components Part number Manufacturer Cost (£) 

C1 uArm Swift Pro Desktop Robotic Arm - 

Professional Kit 
- ufactory 749.98 

 Frame  

C2 Aluminium rail (20 x 20 x 350 mm) x 4 units VSLOT2020 Ooznest 10.08 

C3 Aluminium rail (20 x 40 x 350 mm) x 2 units VSLOT2040 Ooznest 8.82 

C4 Breadboard MB4545/M Thorlabs 184.52 

C5 Clamp x 4 units CL3/M Thorlabs 14.76 

  Subtotal 203.42 

 Printhead (Components per printhead)  

C6 Stepper motor, 3.8 V 5350344 RS 31 

C7 Shaft coupling PSMR19-5-5-A Ruland 18 

C8 
Lead screw (107 mm) 

DST-LS-6.35x2.54-R-

500-ES 
Igus 5.15 

C9 
Lead screw nut 

DST-JFRM-

131315DS6.35X2.54 
Igus 17.25 

C10 Linear rail (100 mm) x 2 units WSQ-06 Igus 8.62 

C11 Linear guide pillow block x 2 units WJ200QM-01-06 Igus 15.74 

C12 Ball bearing 624ZZ NSK 3.65 

C13 Aluminium rail (20 x 40 x 150 mm) VSLOT2040 Ooznest 1.89 

C14 Magnet (Height 3 mm diameter 4 mm) x 6 units M1219-3 Comus 6.12 

C15 Magnet (Height 2 mm diameter 3 mm) x 6 units M1219-2 Comus 2.7 

C16 Stepper motor drive* A4988 Polulu 7.18 

C17 Resistors (10 kΩ 0.6 W)* MF006FF1002KIT Royal Ohm 1.36 

C18 Capacitor 100 µF* EEAGA1A101 Panasonic 0.06 

  Subtotal 118.72 

 Printhead (Components for whole system)  

C19 Power adapter, 9V, 2A VEL18US090-UK-JA XP Power 10.24 

C20 Arduino mega* A000067 Arduino 25 

C21 Breadboard* TW-E40-1020 Twin Industries 4.13 

C22 USB A-male to USB B-male cable* AK-300102-010-S Digitus 0.42 

   Subtotal 39.79 

 Heating (Components per module)    

C23 Power adapter, 9V, 2A (syringe heater) 

Power adapter, 12V, 500mA (stage heater) 

VEL18US090-UK-JA/ 

T6116ST 

XP Power or  

Stontronics 

10.24/ 

4.02 

C24 Type K thermocouple Z2-K-1M Labfacility 4.64 

C25 Thermocouple Amplifier (MAX31855K)* 269 Adafruit 12.76 

C26 MOSFET* IRLR/U8743PBF Infineon 1.04 

C27 Arduino Nano* A000005 Arduino 14.23 

C28 Breadboard* MCO1003 Multicomp 1.10 

C29 USB A-male to USB mini B-male cable* ZUV0E3058769 StarTech 1.4 

  Subtotal ~37 

 Heating (Components for whole system)  

C30 31 AWG Nichrome wire UMNICWIRE2 Ultimachine 5 

C31 High temperature tape 051-0002 Antistat 4.27 

  Subtotal ~50 

 Others  

C32 UV365 LED UV Torch NSUV365 Nightsearcher 162.5 

C33 HD Webcam C922 Logitech 65.1 

C34 Drop-in Tee Nuts, M5 (~200 units) VSLOT-H-DT-M5 OOznest 40 
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 Components Part number Manufacturer Cost (£) 

C35 MakerLink 90 Degree Hidden Tee Nut x 4 units VSLOT-H-ML-90H-GS Openbuilds 4.88 

C36 Universal L Brackets x 4 units VSLOT-B-UL-S-C OOznest 4 

C37 Jumper cables  MIKROE-511 MikroElektronika 2.41 

  Subtotal 278.89 

  TOTAL ~1870 

 51 

  52 
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III. Assembly instruction 53 

Prior to the assembly, the custom-designed parts were 3D printed with PLA or ABS using an 54 

Ultimaker S3 3D printer. A syringe holder and a stage holder were custom-made with 55 

aluminum. All the custom-designed CAD files are listed in Supplementary Table 4 and are 56 

available on Github. 57 

 58 

  59 

 60 

Supplementary Figure 2| a) Overview of the setup. b) 3D printed stages for 61 
accommodating different sizes of receiving reservoirs. c) 3D CAD design of the piston -62 
driven extrusion printhead. Add-on d) UV light for photopolymerization and e) camera 63 
for in situ monitoring.  64 

  65 
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Supplementary Table 4| Customised accessory list. The printing time is referred to the 66 
time required when a ‘fast’ print setting is used in Ultimaker.  67 

  Components Materials Printing time 

Frame 

D1 Rod holder 1 x 2 units 
 

PLA 1 hr 

D2 Rod holder 2 
 

PLA 1 hr 30 min 

D3 Rod holder 3 
 

PLA 1 hr 30 min 

D4 Adapter plate 1 
 

PLA 30 min 

D5 Adapter plate 2 
 

PLA 30 min 

D6 Adapter plate 3 
 

PLA 30 min 

D7 Adapter plate 4 
 

PLA 30 min 

D8 Adapter plate 5  PLA 30 min 

Printhead 

D9 Stepper motor holder 
 

PLA 1 hr 

D10 Lead screw adapter_front 
 

PLA 30 min 

D11 Lead screw adapter_back 
 

PLA 50 min 

D12 Syringe holder_back 

 

PLA 2 hr 

D13 Syringe holder_front 

 

PLA 50 min 

Printhead 

heater 

D14 Stepper motor holder 
 

PLA 1 hr 

D15 Lead screw adapter_front 
 

PLA 30 min 

D16 Lead screw adapter_back 
 

PLA 50 min 

D17 Heating syringe holder_back 

 

ABS 2 hr 20 min 

D18 Heating syringe holder_front 

 

ABS 1 hr 10 min 

D19 Syringe heater barrel_AL 

 

Aluminum n/a 

Stage 

D20 35 mm petri dish stage 
 

PLA 40 min 

D21 55 mm petri dish stage 
 

PLA 1 hr 20 min 

D22 90 mm petri dish stage 
 

PLA 1 hr 20 min 

D23 30 mm rectangular container stage 
 

PLA 40 min 

D24 38 mm rectangular container stage 
 

PLA 1 hr 

D25 75x25 mm glass slide holder 
 

PLA 50 min 

Stage heater 

D26 35 mm petri dish heating stage 1 
 

ABS 30 min 

D27 35 mm petri dish heating stage 2 
 

ABS 30 min 

D28 35 mm petri dish holder_AL 
 

Aluminium n/a 
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II.1 Printhead assembly  68 

Supplementary Figure 3 shows the step-by-step assembly instruction of a printhead. 1. Before 69 

assembling the printhead, the lead screw (Part C8) was milled to the designed dimension. (see 70 

Supplementary Figure 3, step 1). 2. Next, the stepper motor (Part C6) was attached to the 3D 71 

printed motor holder using M2.5 screws. 3. The stepper motor holder was then inserted to an 72 

aluminium rail (Part C2) and locked in place with the drop in tee nuts (Part C34) and M5 73 

screws. 4. A shaft coupling (Part C7) was connected to the motor shaft and tightened using the 74 

built-in set screw. 5. Two 10 cm linear rails (Part C10) were tightened firmly on the aluminium 75 

rail using M5 screws at a position of ~28 mm from the top edge of the aluminium rail. 6. A 76 

linear guide pillow block (Part C11) was inserted to each linear rail. 7. The modified lead 77 

screw was combined with a lead screw nut (Part C9), which was then tightened on a 3D printed 78 

lead screw nut mount. 8. The lead screw was tightened to the shaft coupling, and the 3D printed 79 

lead screw nut mount was then linked to the linear guide pillow blocks on the linear rail using 80 

M4 screws. 9. The end of the lead screw was connected to a ball bearing (Part C12) that was 81 

fit to a 3D printed syringe holder. 10. The 3D printed syringe holder was then tightened on the 82 

aluminium rail using M5 screws and the drop in Tee nuts. 11. The printhead assembly was 83 

finished by placing magnets (Parts C14 & C15) to the designed holes of the lead screw nut 84 

mounts and the syringe holders using super glue.  85 

 86 

The heating printhead was assembled similarly using different 3D printed parts of syringe 87 

holders (Parts D17 & D18) that were custom-made to fit an aluminium barrel (Part D19). The 88 

aluminium barrel was wrapped with a Nichrome wire as the heating wire (Part C30) and a K-89 

type thermocouple (Part C24) as the temperature sensor using a high temperature tape (Part 90 

C31).  91 

 92 

 93 

II.2 Installation of printheads to the frame 94 

The frame of the dispensing module is made of six aluminium rails, and was assembled using 95 

hidden tee nuts and L brackets (Parts C35 & C36) as linkages according to Supplementary 96 

Figure 3. The frame was then fastened on the aluminium breadboard by means of the 97 

customised 3D printed adapters. In total, 4 printheads were built. They were firmly installed to 98 

the frame using the 3D printed adapter plates.  99 
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 100 

Supplementary Figure 3|  Printhead assembly.  101 

 102 

II.3 Installation of 3D printed stage to the robotic arm 103 

All 3D printed stages were designed to mount to the uArm with an adapter piece obtained from 104 

the laser engraving kit of the uArm. To connect the stage to the uArm, first, the adapter piece 105 

was disassembled from the laser engraving kit (see Supplementary Figure 4a, Step 1). The 106 

adapter piece was then attached to the 3D printed stage using M3 screws (Step 2), inserted and 107 

fastened to the uArm using the hand screw of the uArm (Step 3). The uArm was locked firmly 108 

on an aluminium breadboard (Part C4) using clamps (Part C5) (Step 4).  109 

 110 

For the heating stage, an aluminium holder (Part D28) was made for fitting a 3.5 mm petri dish. 111 

The aluminium holder was then wrapped with a heating coil (Part C30) with a K-type 112 

thermocouple (Part C24) placed on the holder using a high temperature tape (Part C31). The 113 

holder was then clamped by two 3D printed parts (Parts D26 & D27) to form the heating stage 114 

(Supplementary Figure 4b). The installation of the heating stage to the uArm was the same 115 

as the procedure mentioned above.  116 
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 117 

 118 

Supplementary Figure 4 | a) Assembly procedure of the stage to the uArm. b) A detailed 119 
view of the heating stage.   120 

 121 

II.4 Electrical circuit of the printheads 122 

Supplementary Figure 5 shows the circuit diagram of a printhead. The stepper motor of the 123 

printhead is controlled by an Arduino board. Before connecting the stepper motor to the 124 

Arduino board, a current limiting procedure was carried out with the motor drive to limit the 125 

loaded current. This procedure was to prevent the loaded current from exceeding the rated 126 

current of the stepper motor, hence avoiding overheating of the stepper motor. The procedure 127 

was carried as follows39. First, the current limit of the motor drive, Imax, and the reference 128 

voltage of the motor drive, Vref, were calculated using the below equations. The actual current 129 

limit of the stepper motor, Irating, is usually 70% of the driver current limit, Imax. Irating is 670 130 

mA according to the stepper motor specification40 and Rcs is the current sense resistance of the 131 

motor drive, which is 0.068 Ω 39. 132 

Imax =
Irating

0.7
=

0.67

0.7
= 0.96 A (1) 

Vref = 8 x Imax x Rcs = 8 x 0.96 x 0.068 = 390 mV (2) 

 133 

Next, an Arduino script was written for running the motor drive in full step mode by setting 134 

the logic levels of the MS1, MS2 and MS3 pins to ‘LOW’. After ensuring the motor was not 135 

connected to the motor drive, the script was uploaded to the Arduino board. A multimeter was 136 

then used to measure the voltage, Vref, between the potentiometer and the GND pin connecting 137 

to the Arduino board (see Supplementary Figure 5). Vref  was tuned to approximately 390 mV 138 

by rotating the potentiometer using a screwdriver.  139 

 140 
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 141 

Supplementary Figure 5| Circuit diagram for connecting a stepper motor with 142 
Arduino and a motor drive. In the current limiting procedure, the stepper motor was 143 
detached from the circuit. Vre f , was measured between the potentiometer and the GND 144 
pin to the Arduino board, as indicated by the red crosses.  145 

 146 

After the current limiting procedure, the stepper motor was connected to the motor drive using 147 

the arrangement shown in Supplementary Figure 5. Overall, a single Arduino mega board 148 

and a power supply were used to control and operate four printheads. Supplementary Figure 149 

6 shows the overall circuit diagram. As an Arduino mega board has 54 digital pins and the 150 

control of each printhead requires 8 digital pins, more printheads can be incorporated into the 151 

system if needed.  152 

 153 

 154 

Supplementary Figure 6| Overall circuit diagram of the dispensing module 155 
composed of four printheads.  156 



14 

 

II.5 Electrical circuit of the heaters 157 

Supplementary Figure 7 shows the circuit diagram of the heating module. The syringe heater 158 

was connected to a power adapter with rating of 9 V and 2 A, whereas the stage heater was 159 

powered by a power adapter with a 12 V and 500 mA rating. An Arduino nano board and a 160 

MOSFET were employed to control each heating module because of their compactness in size.  161 

 162 

 163 

Supplementary Figure 7| Circuit diagram of a heating module.  164 

 165 

 166 

II.6 UV module and camera  167 

A UV light source can be easily mounted onto the aluminium breadboard when needed. Here, 168 

a low power UV light torch (5 W, NSUV365, Nightsearcher) with wavelength of 365 nm. A 169 

camera unit (C922, Logitech) was added onto the breadboard for in-situ monitoring and 170 

recording the printing process.  171 

 172 

 173 

 174 

 175 

 176 

 177 

 178 

  179 
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IV. Maximum build volume  180 

The maximum build volume is estimated by subtracting the weight of the customised stage 181 

from the payload capacity of the robotic arm (see Supplementary Table 5 which provides the 182 

estimated maximum build volume when different built stages are in use). The estimated 183 

maximum build volume is ~ 490 cm3 (assuming the density of the material is equal to 1g/cm3, 184 

i.e. the approximate density of most soft materials). 185 

 186 

Supplementary Table 5| Estimated maximum build volume when different built stages 187 
are in use. 188 

Stages 
Weight of the customised 

stages (g) 

Estimated max. build 

volume (cm3) 

35 mm petri dish stage 8 492 

55 mm petri dish stage 15 485 

90 mm petri dish stage 15 485 

30 mm rectangular container 

stage 
7 493 

38 mm rectangular container 

stage 
11 489 

75x25 mm glass slide holder 10 490 

35 mm petri dish heating stage 20.9 479 

 189 

 190 

V. Theoretical resolution of the printhead  191 

The theoretical volumetric resolution per step of the printhead when using a sixteenth micro-192 

stepping resolution was calculated using below equations23. A microstepping stepper motor 193 

drive (A4988, Pololu) was chosen as it enables five microstep resolutions (full, 1/2, 1/4, 1/8 194 

and 1/16 step)39. The selected stepper motor and the threaded rod have a step angle of 1.8o 195 

and a pitch spacing of 2.54 mm40,41.  196 

 197 

Step per revolution = 360/step angle = 360/1.8 = 200 steps per revolution 198 

Steps per mm = 
1

pitch spacing 
x

1

micro−stepping resolution 
x steps per revolution 199 

= 
1 revolution

2.54 mm
 x

1
1

16

x
200 steps

1 Revolution
= 1260 steps/mm 200 

Dispensing resolution = 1 mm/1260 steps = 0.8 µm per step 201 

 202 
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VI.  Printing demonstration 203 

 204 

Supplementary Figure 8| Fabrication of a) perfusion moulds made of SE1700 and b) a 205 
3D nose model made of Ecoflex using Printer.HM. Both constructs were printed using 206 
CAD files as the geometry inputs. The SE1700 ink was printed with a 25G needle, using 207 
a stage speed of 2 mm/s and an extrusion flowrate of 825 µL/h. The SE1700 construct 208 
was then cured at 70oC overnight. For the ecoflex printing, the ecoflex ink was prepared 209 
following a similar formulation reported in a previous study, where Part A ecoflex 00-210 
30 was mixed with Part B Ecoflex 00-30 (with 1.2w/v% Slo-jo and 1.2 w/v% Thivex) at 211 
1:1 wt. ratio with the addition of a drop of oil -based light orange color ink for 212 
visualisation. The ink was then embedded printed in a 6 w/v% fumed silica – mineral oil 213 
support bath. The printing was performed with a 27G needle, extrusion speed of 825 214 
µL/h and a stage speed of 2 mm/s. The printing time was around 30 min. After printing, 215 
the printed construct was left at room temperature for 2 days for curing before collecting 216 
it from the bath. Scale bars = 5 mm.  217 

 218 

  219 
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VII. Theoretical linewidth calculation 220 

The cross-sectional area, A, of the printed filament, when it is printed at over-extrusion 221 

condition (see Supplementary Figure 9), can be calculated using the following equation: 222 

A =
Q

vdragging
  223 

where Q = Extrusion flowrate and 𝑣𝑑𝑟𝑎𝑔𝑔𝑖𝑛𝑔 = dragging speed of the filament, which can be 224 

assumed as the speed of the stage, 𝑣𝑠𝑡𝑎𝑔𝑒. Therefore,  225 

A =
πd2

4
=

Q

vstage
. 226 

And, the theoretical line width, d, can be calculated as  227 

d = √
4Q

π ∙ vstage
. 228 

 229 

 230 

Supplementary Figure 9| Schematic showing the over-extrusion condition, where the 231 
diameter of the filament, d2 is greater than the nozzle diameter, d1 (die swell ratio > 1).  232 

  233 
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VIII.  Codes for the printing operation  234 

Below shows the user-defined inputs in the Python programme templates for different 235 

geometry inputs. The codes are available on Github. Users only need to define the inputs in the 236 

programme and the operation process will be executed automatically.   237 

 238 

  239 

Supplementary Figure 10| The required inputs in the Python template for using 240 
coordinates as the geometry input  241 

 242 

Supplementary Figure 11| The required inputs in the Python template for using 243 
equations as the geometry input.  244 

 245 

  246 

Supplementary Figure 12| The required inputs in the Python template for using G-code 247 
generated from CAD as the geometry input. The conversion of CAD to G -code was made 248 
using 3D Slic3R, an open-source 3D slicing software.  249 

 250 
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 251 

Supplementary Figure 13| The required inputs in the Python template for using picture -252 
generated G-code as the geometry input. The conversion of picture to G -code was made 253 
using Inkscape, an open-source graphics software.  254 

  255 
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IX.  Conversion of pictures to G-code 256 

Printing with picture input was enabled by the ‘Gcodetools’ extension on Inkscape 257 

(https://inkscape.org/), which was an extension designed for CNC machines. The extension 258 

was installed on Inkscape. To covert a picture into printing paths, the workplace size on 259 

Inkscape was first adjusted according to the size of the stage by clicking ‘File → Document 260 

properties → Custom sizes’. The acceptable form of pictures can be photos of hand-drawn 261 

sketches, pictures created by any drawing software or drawings created on Inkscape. For photos 262 

of hand-drawn sketches or pictures created by other drawing software, the pictures were 263 

imported to Inkscape and were converted to a vector path using the following procedures: 1) 264 

Convert the image to a binary image (‘Filters → Color → Greyscale’) and 2) Trace the 265 

centreline of the image (‘Extensions → Images → Centerline Trace 0.8a → Select ‘Replace 266 

image with vector graphics’ and ‘Trace bright lines’). For drawings created on Inkscape, the 267 

drawing was converted to paths by clicking ‘Path → Object to path’. After converting the 268 

picture to path, the path was then placed at the centre of the workplace and was converted to a 269 

G-code file by applying the following step: 1) Navigate to ‘Extensions → Gcodetools → 270 

Orientation points’ and select ‘2-points mode’, 2) click ‘Extensions → Gcodetools → Tool 271 

library’ and select ‘Cone’; and 3) Select the path, navigate to ‘Extensions → Gcodetools → 272 

Path to Gcode’ and save the file by clicking ‘Apply’ under the ‘Path to Gcode’ tab with the file 273 

name defined in the ‘Preferences’ tab. The generated file was then imported to the Python 274 

programme for the picture input (See Supplementary Figure 12), which was designed for 275 

reading the G-code files generated by this extension. 276 

277 
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X. Ink preparation  278 

Supplementary Table 6| Formulations of the inks and support baths used in this 279 
work. Concentration is expressed as w/v% unless specified.  280 

Inks 
Support baths / 

matrices 
Heating / UV Figures 

30% Pluronic F127 - Stage heating at 40oC 2a (Hand) 

40% Pluronic F127 

1.3% xanthan gum: 

PEGDA 700: I2959 

(10:1:1 vol. ratio) 

Syringe heating at 50oC 
2a (Vascular 

network) 

68 wt% methacrylate hydroxypropyl 

cellulose
42

 
- UV 2a (Letter H) 

PEGDA 700: DIW: I2959 (2:8:1 vol. 

ratio) 
1% Carbopol - 2b  

Collagen 4.5% gelatin slurry - 2b 

SE1700 (base:catalyst at 10:1 wt. 

ratio) 
- - 

2b, 

Supplementary 

Figure 8 

10% Sodium carboxymethyl cellulose - - 2b 

40% Pluronic F127 - - 2c, 2d 

SE 1700  - - 
3a (Rectangular 

container) 

40% Pluronic F127 - - 3a (Triangle) 

40% Pluronic F127  
10% gelatin + 1.3% 

xanthan gum 
Stage heating at 40oC 3a (Channel) 

SE 1700 - - 3b (Sine wave) 

30% Pluronic F127 - Stage heating at 40oC 3b (Tube) 

40% Pluronic F127 - - 
3b (Butterfly 

curve) 

40% Pluronic F127 2% agarose - 3b (Circle) 

30% Pluronic F127 - Stage heating at 40oC 3c (Hand) 

15% hydroxyapatite + 5% alginate, 

pre-crosslinked with 200 mM CaCl2 
- - 3c (Femur) 

10% Sodium carboxymethyl cellulose - - 3c (leaf) 

10% alginate, pre-crosslinked with 

200 mM CaCl2 
1.3% xanthan gum - 

3c (grid and Y-

shaped tube) 

40% Pluronic F127 

1.3% xanthan gum: 

PEGDA 700: I2959 

(10:1:1 vol. ratio) 

Syringe heating at 50oC 3d.i  

40% Pluronic F127 - - 3d.ii  

25% polyacrylic acid 
Fumed silica-mineral 

oil bath 
- 3d.iii  

3T3 cell suspension - - 4a 

40% Pluronic F127 1% Carbopol - 4b  

40% Pluronic F127 - - 4c 

40% Pluronic F127 - - 6b 

3% Sodium hyaluronate 1% Carbopol - 6c.i 

10% alginate, pre-crosslinked with 

200 mM CaCl2 
1.3% Xanthan gum - 6c.ii – 6c.iii 

Part A:Part B Ecoflex 00-30 (with 

1.2w/v% Slo-jo and 1.2 w/v% 

Thivex) (1:1 wt. ratio) 

- - 
Supplementary 

Figure 8 

 281 

282 
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XI.  Supplementary videos 283 

Supplementary Video 1: Video showing the fabrication of a rectangular container using 284 

coordinates as the geometry input. 285 

 286 

Supplementary Video 2: Video showing the printing of a butterfly pattern using equations 287 

as the geometry input. 288 

 289 

Supplementary Video 3: Video showing the printing of a vascular-like structure using a 290 

CAD file as geometry input. 291 

 292 

Supplementary Video 4: The morphing of a flower-like construct made of poly(acrylic acid) 293 

in 1M Tris solution. The flower-like construct was designed with heterogeneous printing and 294 

was printed using the geometry input of picture. 295 

 296 

Supplementary Video 5: Dispensing of cell suspension using Printer.HM 297 

 298 

Supplementary Video 6: Video demonstrating the non-planar printing capability of 299 

Printer.HM. A pluronic line pattern was printed on the non-planar surface of a nose model. 300 

 301 

Supplementary Video 7: Video demonstrating the pick-and-place operation. 302 

 303 
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